Script halted! SharePoint setup requires a restart. Run the script again after restarting to continue

Topics: Feedback, General Questions, Support
Nov 4, 2014 at 6:15 PM
I am new to AutoSPInstaller and I am trying install SharePoint 2013 on Oracle Virtualbox.

I am having an issue when the installation stuck on the step " Installing SharePoint 2013 Binaries.... Done". Then I saw the message "Script halted! [SharePoint setup requires a restart.] Run the script again after restarting to continue." It seems this message keeps looping again and again.

I need to get SharePoint installed. Please let me know if you have experienced this or any workaround solution I can resolve this.

I tried to enclosed an image but I couldn't.Image

Thanks very much in advance.

Here is the code that I found from the AutoSPInstallerFunctions.ps1

# Get error(s) from log
        $setupLastError = $setupLog | Select-String -SimpleMatch -Pattern "Error:" | Select-Object -Last 1
        $setupSuccess = $setupLog | Select-String -SimpleMatch -Pattern "Successfully installed package: oserver"
        If ($setupLastError -and !$setupSuccess)
        {
            Write-Warning $setupLastError.Line
            Invoke-Item -Path "$((Get-Item $env:TEMP).FullName)\$setupLog"
            Throw " - Review the log file and try to correct any error conditions."
        }
        # Look for restart requirement in log
        $setupRestartNotNeeded = $setupLog | select-string -SimpleMatch -Pattern "System reboot is not pending."
        If (!($setupRestartNotNeeded))
        {
            Throw " - SharePoint setup requires a restart. Run the script again after restarting to continue."
        }

        Write-Host -ForegroundColor Blue " - Waiting for SharePoint Products and Technologies Wizard to launch..." -NoNewline
        While ((Get-Process |?{$_.ProcessName -like "psconfigui*"}) -eq $null)
        {
            Write-Host -ForegroundColor Blue "." -NoNewline
            Start-Sleep 1
        }
        Write-Host -ForegroundColor Green "Done."
        Write-Host -ForegroundColor White " - Exiting Products and Technologies Wizard - using PowerShell instead!"
        Stop-Process -Name psconfigui