Support of MS slipstreamed SP2013 with SP1

Topics: General Questions, Support
Mar 9, 2014 at 3:50 PM
Hi all,
I have used your fantastic script for couple of installations and its really great work ! Actually I have tried to install the "new" SharePoint 2013 with SP1 (ENU) plus German language pack on a Windows Server 2012 R2 (ENU).
Unfortunatly this does not work. So far I found that MS changed the name and probably the content of the Language Pack file. Even more it is not able to create the configDB.


New-SPConfigurationDatabase : This content database requires upgrade and could not be attached in this operation. Use
either the [stsadm -o addcontentdb] command or [Mount-SPContentDatabase] cmdlet instead.
At C:\SPinst\AutoSP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1562 char:13
  • New-SPConfigurationDatabase -DatabaseName "$configDB" -DatabaseServe ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...urationDatabase:SPCmdletNewSPConfigurationDatabase) [New
      -SPConfigurationDatabase], SPUpgradeException
    • FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPConfigurationDatabase
Are there plans to "upgrade" script ??

Thanks in advance !
Mar 10, 2014 at 3:35 AM
Script has been updated to support SP1, but I have not got around to testing with language packs yet. Should be happening in the coming days and weeks.

Mar 10, 2014 at 6:39 AM
A W E SO M E Job !! You're acting and answering quicker than I can produce problems :-))

Luckily I have a lab environment available. So I'll download and test the updated script.
Regarding the language pack issue: I think this was not a script Problem, it was a "layer 8" Problem.... I used the bit's and bytes from Language pack SP1 NOT from language pack itself ;-(( My fault. Will Keep also an eye of that item !!

Go ahead with your EXCELLENT work and thanx a lot !

Marked as answer by brianlala on 3/23/2014 at 6:05 AM
Mar 23, 2014 at 12:26 PM
Hi Brian,

slipstreamed SP2013 with SP1, this is a great news. Quick question, When I use AutoAPInstaller, do I need to slipstreame both PU and SP1 or just SP1?
Mar 23, 2014 at 12:48 PM
Hi pxw,
Just SP1 is enough.
Marked as answer by brianlala on 3/23/2014 at 6:05 AM