This project has moved and is read-only. For the latest updates, please go here.

Get-AdministratorsGroup function returns nothing on domain controller

Feb 26, 2013 at 6:01 PM
Any reason why the function Get-AdministratorsGroup in AutoSPInstallerFunctions.ps1 would return nothing on a domain controller running Windows Server 2008 R2? I hard-coded a return value of "Administrators" in order to get past the error caused by that function not returning a value. Thanks in advance for any ideas!
Mar 1, 2013 at 7:07 PM
Edited Mar 1, 2013 at 7:08 PM
On a DC the local administrators group is actually stored in AD. If you look in ADUC, there is a 'Builtin' container where the local user objects are stored. I don't believe the Get-AdministratorsGroup handles this special scenario. And realistically, SharePoint should not be installed on a DC in the first place, though sometimes development environments are setup this way.
Mar 5, 2013 at 2:26 AM
FWIW I installed SharePoint on my own local test single-server environment (where the server is a DC) about 3 times today repeatedly and didn't run into any problems.

Mar 5, 2013 at 11:12 AM
Brian - thanks for your reply. There was something seriously wrong with WMI on that machine (which happened to be the first machine I had ever tried AutoSPInstaller on)...the various Win32_Group commands just didn't work. I have since tried it on other machines and, of course, it works without any issues.