SP2010 Error Provisioning Word Automation Services

Feb 24, 2013 at 8:53 PM
Edited Feb 24, 2013 at 9:00 PM
Oops the title was supposed to read SP2013....

The following error is being thrown when you include Word Automation Services in the configuration with SP2013.

I can manually provision this without error with the below PS
Write-Host "Creating Word Conversion Service and Proxy..."
New-SPWordConversionServiceApplication -Name $WordAutomationSAName -ApplicationPool $saAppPoolName -DatabaseServer $databaseServerName -DatabaseName "SharePoint_WordAutomation" -Default > $null
Get-SPServiceInstance | where-object {$_.TypeName -eq "Word Automation Services"} | Start-SPServiceInstance > $null
Please Advise!
--------------------------------------------------------------
 - Provisioning Word Automation Services...
 - Failed to get service instance - check product version (Standard vs. Enterprise)
At E:\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1572 char:34
+         If (!$serviceInstance) { Throw " - Failed to get service instance - chec ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: ( - Failed to ge...vs. Enterprise):String) [], RuntimeException
    + FullyQualifiedErrorId :  - Failed to get service instance - check product version (Standard vs. Enterprise)

Press any key to exit...
--------------------------------------------------------------
--------------------------------------------------------------
============================================================

Confirguration Settings for Word Automation Services

<WordAutomationService Provision="true" Name="Word Automation Services" ProxyName="Word Automation Services">
      <Database>
        <Name>WordAutomation</Name>
        <DBServer>wfe01.contoso.com</DBServer>
        <DBAlias Create="false" DBInstance="SERVER\INSTANCE" DBPort="" />
      </Database>
    </WordAutomationService>
Feb 24, 2013 at 9:07 PM
I have also discovered that if you have
  • Excel Services
  • Visio Services
  • Access Services
    Enabled to provision but do not have Word Automation Services Provisioning enabled, the same error is thrown when attempting to configure SP2013.