Creating Metadata Service Application hangs

Dec 8, 2012 at 7:20 PM

Hi all,

I am actually trying to deploy SP2013 with the script. Unfortunately it hangs at the "Creating Metadata Application". If I stop the script and re-start it, it recognize that there is a Metadata Application and jumps over this step. But there is only the App, no Proxy and therefore I realize lots of Errors afterwards.

Did anybody has already solved this issue ?

Regards

Martin

Coordinator
Dec 10, 2012 at 2:31 AM

I've experienced the very same error. Nothing I can identify within the script is causing this, it's really just a couple of native SP2013 PowerShell cmdlets attempting to create the Metadata Service App. Maybe it's a case of trying to complete the previous command in the script (although no 'conflict' type errors are thrown in the output). Next time it happens to me I'll dive into the ULS logs to try to determine what's going on though. Maybe a good old Start-Sleep is needed somewhere in there...

Brian

Dec 10, 2012 at 6:45 AM

Brian,

thanks for quick reply !

Well, I am "glad" that you're experiencing the same issue - I start to become mad :-) Ok, I'll also try to look into it. May this won't be an issue soon....

Regards

Martin

Jul 29, 2013 at 1:23 PM
Hi !

Is there a way to add a server reboot just before Metadata service part ?

I'm not familiar enough with PowerShell to alter the script myself, can you advice please ?

Thanks !


SZ
Jul 30, 2013 at 8:56 AM
You can write the following:
Restart-Computer -ComputerName localhost
Just search the AutoSPInstallerFunctions.ps1 and place that line where you want it to restart. As Brian indicated, you may just need a "Start-Sleep 5" instead of restarting.
Jul 31, 2013 at 11:16 AM
Ok thanks Wahid !

I'll try the Start-Sleep workaround first :)