This project has moved and is read-only. For the latest updates, please go here.

Prereg install fails on IIS/.NET 4 configuration

Dec 3, 2012 at 10:37 PM
Edited Dec 3, 2012 at 10:38 PM


(Sharepoint 2013 on windows 2008 R2)

The script is failing at




WARNING: 2012-12-03 17:21:32 - Error when enabling ASP.NET v4.0.30319


WARNING: 2012-12-03 17:21:32 - Error: The tool was unable to install

Application Server Role, Web Server (IIS) Role.

WARNING: 2012-12-03 17:21:32 - Last return code (-2146646015)

- A known issue occurred configuring .NET 4 / IIS.


- Setting AutoSPInstaller information in the registry...



I was able to bypass the issue by running the command

%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i –enable

Is there a way to add this to the script?


Dec 4, 2012 at 4:10 AM

Sure, but at which point would you run that command?


Dec 4, 2012 at 1:37 PM

Once, .net v4.5 has been installed, as the script halts after that.


Dec 4, 2012 at 2:36 PM

I had similar issues when using a sysprepped Windows Image which had .NET installed as part of the sysprep. My solution was to use a clean Windows image.

Dec 4, 2012 at 9:34 PM

I did do a clean windows install and that worked, only thing I saw is there was a warning message that popped up to run WCF Data Services, I had to click OK for it to continue.

Has anyone else seen this?

Apr 26, 2013 at 3:38 PM
I ran into this problem too, but only in a production environment installing SP 2013 on Windows 2012 Servers.

Windows Server 2012 uses Windows Update to install some features needed for the Web Server role. Im my case, a GPO to configure WSUS for windows updates actually broke Windows Update instead of disabling it throwing one of the remote WFE servers into an infinite loop of reboots.

Not sure why the GPO had only affected one of the servers. When I tried to run Windows Update by clicking check for updates I get a Windows Update error 800b0001. I fixed Windows Update by removing certain registry entries identified in the Technet article "Configure Automatic Updates using Registry Editor".

When the script fails during the second remote install - what is the best course of action? I hit enter at the prompt and the script continued with the third remote install...