RemoteInstall is NOT set to "True"

Jul 9, 2012 at 3:53 PM
Edited Jul 9, 2012 at 3:57 PM


 I am trying to run ver 3.0.3.

 Although my input file show the <RemoteInstall> "True"

 I get the following error immediately upon running....

- There are other servers specified as farm members in:

- D:\SP-Scripts\SP2010\AutoSPInstaller\\AutoSPInstallerInput.xml

- but <RemoteInstall> is not set to "true" - nothing else to do.

- Completed!


 Here are a few lines from the input file:

        <!-- Set RemoteInstall to true to attempt a centralized, remote install & config of your entire farm -->
        <!-- ParallelInstall controls whether SharePoint binary file installs are triggered simultaneously on all servers in the farm. Can speed things up considerably (unless of course all your VMs are running on the same host, sharing I/O resources etc.!) -->

This is the output from the powershell cmd window: 

Cannot convert value "System.Object[]" to type "System.Xml.XmlDocument". Error: "Name cannot begin
with the '"' character, hexadecimal value 0x22. Line 340, position 53."
At D:\SP-Scripts\SP2010\AutoSPInstaller\AutoSPInstallerMain.ps1:9 char:15
+ [xml]$xmlinput <<<<  = (Get-Content $InputFile) -replace ("localhost", $env:COMPUTERNAME)
    + CategoryInfo          : MetadataError: (:) [], ArgumentTransformationMetadataException
    + FullyQualifiedErrorId : RuntimeException

You cannot call a method on a null-valued expression.
At D:\SP-Scripts\SP2010\AutoSPInstaller\AutoSPInstallerFunctions.ps1:4099 char:44
+     ForEach ($node in $xmlinput.SelectNodes <<<< ("//*[@Provision]|//*[@Install]|//*[CrawlServers
    + CategoryInfo          : InvalidOperation: (SelectNodes:String) [], RuntimeException
    + FullyQualifiedErrorId : InvokeMethodOnNull