Adding new WFE: Farm not found so new one created. Now won't connect to existing farm

Jan 11, 2012 at 4:08 AM

We ran the SPInstaller on a WFE03 server that we wanted to add into an existing farm. The script did not join the server to the existing farm despite the configDB being correct in the AutoSPInstallerInput.xml file. The commenting said that it was creating a new farm and later it was aborted due to no SQL permissions.

For various reasons, we have since run the SharePoint Configuration wizard to try and join the server to the farm. We enter the SQL server and DB name that the current farm is using. This does not add the new server to the existing farm - it provisions another Central Administration site on the new server.

If I go into Central Admin on the original farm's WFE > Manage servers in farm, I can't see the new server in the list. I can open the second farm's Central Admin site from the new server and go to Manage servers in farm and it's the only one in there.

What is confusing me is that both farms are using the same configDB: SP_ConfigDB on SQL02. The original farm is still fully functional.

I think the SPAutoInstaller has made a mess of something because I cannot add this new server to the farm.

Jan 12, 2012 at 5:48 AM

I am having the same issue of "no existing farm found" issue.  I had used AutoSPInstaller to build an APP server (w/ most of services and CA, but w/o web apps) just fine.  In SQL, I see all the DBs were created fine. CA page looks good and I see APP and SQL boxes in the server list.

Now, when I try using the script (a bit different from what I used for APP) for WFE, it basically bombs trying to create ConfigDB again as it failed to detect the existing farm.

It seems like it was brought up some of discussions and issues. Brain, you mentioned suspecting securtity setting issue unable to see ConfigDB. The script I am using for this WFE has identical credentials I used for successful APP server build.  I tried to give a god-power to install account in SQL box, still no luck...


(this script is brillient, btw)

- Checking farm membership for SPFARMWFE1 in "SPFarm_ConfigDB"...
- Attempting to join farm on "SPFarm_ConfigDB"...
- No existing farm found.
- Creating config database "SPFarm_ConfigDB"...
New-SPConfigurationDatabase : SPFarm_ConfigDB on SQL2k8r2 contains user-defined
schema. Databases must be empty before they can be used. Delete all of the t
ables, stored procedures and other objects or use a different database.

Jan 12, 2012 at 7:05 AM


On WFE install (2nd server after successful install of very 1st server - dedicated APP), script errors out with giving "No Existing Farm Found" error.

It was basically complaining about Connect-SPConfigurationDatabase command which bombs with error something like "...set of installed products" are different than Farm.  (Error was only visible after removing "ErrorAction" from the line)

The discrepancy of installed products was resolved by uninstalling "WebApp", which was installed on this WFE in the very first run of script (which failed for some other reason).

So, what had happened here was that, my very first script run on WFE "failed" somewhere leaving the WebApp in the WFE (which was deliberately not installed in APP), which then caused the diff set of installed products, which caused joining to the farm failed in subsequent trial of script run.

To fix: I removed WebApp from Installed App and reran the line.

Aug 21, 2012 at 8:24 PM
Edited Aug 22, 2012 at 1:05 AM

To fix: I removed WebApp from Installed App and reran the line.

Not sure I understand... Where did you do this?

I am getting this sometimes after the 2nd server (After the main installed server) and then sometimes after the 3rd server.  There has got to be a fix for this...

Oct 25, 2012 at 12:40 AM

Had the same error message. Simple reason was wrong Farmphrase in new Server script.