Fails immediatly

Oct 26, 2011 at 8:15 PM
Edited Oct 26, 2011 at 8:16 PM

When i try and run teh autospinstaller.bat a command prompt opens with:

Using standard Input File.
Checking for Powershell 2.0...
PS ExecutionPolicy is RemoteSigned, setting ExecutionPolicy to Bypass.

Running AutoSPInstaller PowerShell script...

You can safely close this window if you want your PowerShell
Execution Policy to remain as "Bypass".
Otherwise, wait for the AutoSPInstaller script to complete,
then press a key, and it will be set to "RemoteSigned".

If you press a key before the script finishes it may not complete as expected
in which case simply re-run this batch file to continue AutoSPInstaller

press any key to continue . . .

When i press any key it sets to remotesigned and i cant get it to run. 

Any Ideas? 

I have used the older installers in the past with out any issues.

Oct 26, 2011 at 8:39 PM

autospinstaller hates it when there is a space in the path leading to the .bat file. 

Oct 27, 2011 at 12:02 PM

I dont understand?  Where would the space be?  I am running the bat file when i get this.  A powershell screen pops up for about 1 second and then disapears.  I cant get it pause so that i can read the message.  The only edits i have made are to xml file and even then i made them match all settings from a prevous version i used..  I have  tried downloading the autoinstaller again and starting over but i get the same results. 

Oct 27, 2011 at 2:06 PM

does any one know how i can get the powershell popup to freeze on the screen so that i can see what the error message is?

Oct 27, 2011 at 2:25 PM

The spaces Joseph is referring to might be in the full path to the AutoSPInstallerLaunch.bat, for example:

C:\SharePoint Installer\SP2010\AutoSPInstaller\AutoSPInstallerLaunch.bat

The batch file blows up pretty suddenly if there is a space in that path, so check yours and remove any spaces in parent folders.

I've found the same challenges in trying to freeze the powershell popup; I actually resorted to a screen recording utility like Community Clips (I think SnagIt does similar stuff too) and then re-playing it. Check for spaces in your path first though.


Oct 27, 2011 at 2:28 PM

LOL!!!! Thank you so much!!! I cant believe that i have been pulling my hair out over this and the whole time its because i renamed the sp2010 folder to sp2010 2.5 so that i could keep my version in check. 


Thank you joseph and you brian!!!

Oct 27, 2011 at 3:32 PM

Now that the script is finally running it seems to be stuck at starting the provisioning user profile sync service.  Its been running at this step for almost an hour now.  I dont remember that being normal the last time I installed using this script?


Dec 17, 2011 at 3:59 AM

Hi @stanleyj42, still an issue or have you worked around the problems in this discussion?


Dec 19, 2011 at 12:27 PM


Its actually been so long since i posted this i cant remember what was the end result was for the profile service.  It must have finally finished since i used the script to setup my production environment and everything is running smoothly.  Thank you so much for this script because it has made life SO much easier when it comes to getting a standard install setup for multiple environments.

Im sorry for not posting back whent he issue was resolved.

Dec 19, 2011 at 2:17 PM

No worries, glad it all worked out.