Creating User Profile Service Application

Jul 8, 2011 at 3:36 PM

Hi,

I have a problem with the AutoSPInstaller Version 2.50.

The script runs for a while, and later it opens an extra powershell window for Creating User Profile Service Application.

In this window i'm getting this error:

Creating User Profile Service Application as XX\XXX
New-SPProfileServiceApplication : Method not found: 'Microsoft.SharePoint.Admin
istration.SPIdentifierType Microsoft.SharePoint.Administration.SPAce`1.get_Bina
ryIdType()'.
At C:\AutoSPInstaller-ScriptBlock.ps1:3 char:56
+ $NewProfileServiceApp = New-SPProfileServiceApplication <<<<  -Name "User Pro
file Service Application" -ApplicationPool "SharePoint Hosted Services" -Profil
eDBName ProfileDB -ProfileSyncDBName SyncDB -SocialDBName SocialDB -MySiteHostL
ocation "http://XXXX:8080"
    + CategoryInfo          : InvalidData: (Microsoft.Offic...viceApplication:
   SPCmdletNewProfileServiceApplication) [New-SPProfileServiceApplication], M
  issingMethodException
    + FullyQualifiedErrorId : Microsoft.Office.Server.UserProfiles.PowerShell.
   SPCmdletNewProfileServiceApplication

C:\AutoSPInstaller-ScriptBlock.ps1 :  - Failed to create User Profile Service A
pplication
At line:1 char:35
+ C:\AutoSPInstaller-ScriptBlock.ps1 <<<<
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
   tion
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
   n,AutoSPInstaller-ScriptBlock.ps1

Anybody here who has an idea?

Best regards,

Robert