This project has moved and is read-only. For the latest updates, please go here.

Error: Update-SPSecureStoreApplicationServerKey : Master secret key is not present in the database.

Mar 17, 2010 at 1:34 PM

I get an error message the first time i run the script. If i run the script second time it works fine. I did notice that there was a mssing space in the this statement

Update-SPSecureStoreApplicationServerKey -ServiceApplicationProxy $secureStore.Id-Passphrase $FarmPassPhrase

Even i add that extra space it does not make a difference.

Following is the detailed error message

 - Creating the Application Key...
Update-SPSecureStoreApplicationServerKey : Master secret key is not present in the database.
At C:\temp\AutoSPInstaller-SP2010RC\AutoSPInstaller.ps1:773 char:43
+         Update-SPSecureStoreApplicationServerKey <<<<  -ServiceApplicationProxy $secureStore.Id -Passphrase $farmPass
    + CategoryInfo          : InvalidData: (Microsoft.Offic...cationServerKey:SPUpdateSPSecur...cationServerKey) [Upda
   te-SPSecureStoreApplicationServerKey], SecureStoreServiceException
    + FullyQualifiedErrorId : Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPUpdateSPSecureStoreApplicationSer

 - Setting the unattended account for Performance Point Services...


Mar 17, 2010 at 2:49 PM

Thanks a lot for pointing out the missing space! You're right though, it doesn't seem to make a difference as I myself get that same error sometimes (and re-running the script a second time works fine). I'm not sure why that message comes up - hopefully it's a Beta/RC issue that will be resolved in RTM. It's quite random though, and in my experience seems to happen more in slower VMs, maybe there's a timeout or concurrency issue, not sure.

Thanks, Brian

Apr 29, 2010 at 1:47 AM

Mate I'm getting the same issue in the RTM.

What are the ramifications of this do you know?

WHen I try and run Gary LaPointe's Search script it fails on Get-SPManagedAccount, seems that it returns the account but SecurePassword returns $null :-(

Apr 29, 2010 at 2:52 AM

Yup me too. I updated Issue 12849 with details of a workaround. Still not sure if there really are any ramifications, or if it's fine just to succeed on a second or subsequent attempt (I'm thinking the latter).

I get similar issues as well with Gary's script. Funny thing is too, if I run it a second time, it works... 2nd time's a charm with PS and SharePoint it seems?

Apr 29, 2010 at 3:21 AM

If i run Gary's script a second time it i get exactly the same errors. is that what you meant? or run your script again?

Is there an easy way to simply run that create secure stoer service function in your script without running the rest? e.g. as it failed the first run through?