1
Vote

AutoSPInstaller for Sharepoint 2016 failing topology service is not available

description

I am using the lastest version of AutoSPInstaller and I am getting the following error after the binaries are setup and at the beginning of installing service applications. I am using Server 2016 and sql server 2016 developer edition on a seperate se3rver 2016 server . I am setting up Sharepoint 2016 with a single web front end and separate database server in my lab. I have attached my input file as wel
  • Waiting for Metadata service...Online
  • Creating Metadata Service Application...
  • Creating Metadata Service Application Proxy...
    New-SPMetadataServiceApplicationProxy : __The topology service is not available in the farm.__
    At E:\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:2505 char:44
  • ... eAppProxy = New-SPMetadataServiceApplicationProxy -Name $metadataServ ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Share...ataServiceProxy:SPCmdletNewMetadata
      ServiceProxy) [New-SPMetadataServiceApplicationProxy], SPException
    • FullyQualifiedErrorId : Microsoft.SharePoint.Taxonomy.Cmdlet.SPCmdletNewMetadataServiceProx
      y
  • Failed to create Metadata Service Application Proxy
    At E:\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:2506 char:32
  • ... (-not $?) { Throw " - Failed to create Metadata Service Application P ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : OperationStopped: ( - Failed to cr...plication Proxy:String) [], Ru
      ntimeException
    • FullyQualifiedErrorId : - Failed to create Metadata Service Application Proxy

  • Script halted!
  • Error provisioning the Managed Metadata Service Application
    Press any key to exit...

file attachments

comments

Goakes wrote Jan 21 at 1:54 PM

rerunning the AutoSpInstaller does not work as it never gets past this error.