This project has moved. For the latest updates, please go here.
5
Vote

Update-SPSecureStoreMasterKey : Secure Store Service did not performed the operation.

description

Found another bug, perhaps there should be a check to make sure Token Service is running before allowing the script to attempt to build a Secure Store Service:
  • Provisioning Secure Store Service Application...
  • Starting Secure Store Service Instance...
  • Waiting for Secure Store service...Online
  • Creating Secure Store Service Application...
  • Creating Secure Store Service Application Proxy...
  • Done creating Secure Store Service Application.
  • Creating the Master Key...
    Update-SPSecureStoreMasterKey : Secure Store Service did not performed the operation.
    At C:\USPTO\AutoSPInstaller_back\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:3939 char:13
  • Update-SPSecureStoreMasterKey -ServiceApplicationProxy $secureStore. ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidData: (Microsoft.Offic...eStoreMasterKey:SPUpdateSPSecureStoreMasterKey) [Update-
      SPSecureStoreMasterKey], FaultException
    • FullyQualifiedErrorId : Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPUpdateSPSecureStoreMasterKey
  • Creating the Application Key...
  • Done creating/configuring Secure Store Service Application.

comments

bretzlaff wrote Oct 24, 2016 at 3:50 PM

Thanks for the great tool! I am experiencing the exact same error for a SP2013 install.

wrote Feb 21 at 11:40 AM

wrote Mar 28 at 5:47 PM

AshokGopalan wrote Mar 28 at 6:18 PM

Found the same issue when the first App server configured in the farm enabled the Secure Store Service and the second App server was also selected to provision the service in the AutoSpInstaller XML file.

Fails at the following line
Write-Host -ForegroundColor White " - Creating the Master Key..."
Update-SPSecureStoreMasterKey -ServiceApplicationProxy $secureStore.Id -Passphrase $farmPassphrase

Could it be because the farm passphrase used has not changed and the Update-SPSecureStoreMasterKey is trying to update with the same passphrase? If the Service Application is already created, do we need to update the master key again if you are only adding additional servers for this service?