1
Vote

Stuck at this error...

description

I have researched this error until I am blue. Can someone help me get past it? I updated the Input file using the latest gui and gets stuck this point. " - Script halted!
Exception : Microsoft.SharePoint.SPException: This SharePoint farm currently has pending upgrades. The cmdlet Mount-SPConfigurationDatabase cannot be executed until the upgrade is completed."

I have checked that the AD accounts have the proper rights to the SQL server and they do. I have included more of the install logs so you can see what happened before the halt.

  • Testing access to SQL server/instance/alias: DB04T\SP13
  • Trying to connect to "DB04T\SP13"...Success
  • SQL Server version is: 11.0.2100.60
  • This instance of SQL Server is not clustered
  • Check if xxx\Install has dbcreator server role...Pass
  • Check if xxx\install has securityadmin server role...Pass

- Check if xxx\install has sysadmin server role...Pass

  • Install based on:
    • C:\SP2013_Installation_files\AutoSPInstaller\AutoSPInstallerInput.xml
    • Environment: Test

- Version: 3.93

- Disabling Loopback Check...


- Disabling IE Enhanced Security...


  • Setting services Spooler, AudioSrv and TabletInputService to Manual...
  • Spooler is already stopped and set Manual, no action required.
  • AudioSrv is already stopped and set Manual, no action required.
  • TabletInputService is already stopped and set Manual, no action required.
  • Setting unused services WerSvc to Disabled...
  • WerSvc is already stopped and disabled, no action required.

- Finished disabling services.


- Not changing CRL check behavior.


- SharePoint 2013 prerequisites appear be already installed - skipping install.


  • Configuring IIS logging...

- C:\Logs is already compressed.


- SharePoint 2013 binaries appear to be already installed - skipping installation.


  • No language packs found in C:\SP2013_Installation_files\2013\LanguagePacks, skipping.
  • Currently installed languages:

- English (United States)


  • Looking for SharePoint updates to install...
    • Installing SP2013 March 2013 Public Update ubersrvsp2013-kb2767999-fullfile-x64-glb.exe....Done.
    • Patch already installed
    • March 2013 Public Update install completed in 00:00:05.
    • Installing SharePoint Cumulative Updates:
    • Installing ubersrv2013-kb2817616-fullfile-x64-glb.exe.......Done.
    • Patch not required; installed product is same or newer.
    • ubersrv2013-kb2817616-fullfile-x64-glb.exe install completed in 00:00:20.
    • Cumulative Update installation complete.

- Finished installing SharePoint updates.

- SharePoint 2013 binary file installation done!

  • Adding xxx\SP13T_Farm to local Administrators ...

- xxx\SP13T_Farm is already a member of "Administrators".


- Loading SharePoint Powershell Snapin...


  • Checking farm membership for xxx-SP13T in "SP13_ConfigDB"...

- Attempting to join farm on "SP13_ConfigDB"...

  • Script halted!
Exception : Microsoft.SharePoint.SPException: This SharePoint farm currently has pending upgrades. The
                    cmdlet Mount-SPConfigurationDatabase cannot be executed until the upgrade is completed.
                       at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord 
                    errorRecord)
TargetObject :
CategoryInfo : InvalidOperation: (:) [Connect-SPConfigurationDatabase], SPException
FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletConnectSPConfigurationDatabase
ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
ScriptStackTrace : at CreateOrJoinFarm,
                    C:\SP2013_Installation_files\AutoSPInstaller\AutoSPInstallerFunctions.ps1: line 1363
                    at Setup-Farm, C:\SP2013_Installation_files\AutoSPInstaller\AutoSPInstallerMain.ps1: line 184
                    at <ScriptBlock>, C:\SP2013_Installation_files\AutoSPInstaller\AutoSPInstallerMain.ps1: line 
                    362
                    at <ScriptBlock>, <No file>: line 1
PipelineIterationInfo : {}
PSMessageDetails :

comments

wahidsaleemi wrote Oct 8, 2013 at 4:44 PM

I would try deleting the ConfigDB and rerunning this.

areenan wrote Oct 8, 2013 at 5:33 PM

I did delete the ConfigDB on the SQL server ,with my SQL admin's supervision, and this is when the error started. I can remote to the Sql server and able to access the Instance. I gave the install user every security option. Still get this error. I even tried to create a new instance with a different name in the install script. Still get the error.

wahidsaleemi wrote Oct 9, 2013 at 9:02 PM

I see. Try running PSConfigUI, not sure that will actually work. The error you're getting is not really related to a database access/security problem:
This SharePoint farm currently has pending upgrades.

MikeEggert wrote Oct 16, 2013 at 2:18 PM

When you see this error: "This SharePoint farm currently has pending upgrades."
Run this command: "psconfig -cmd upgrade -inplace b2b"

The error is displayed for multiple reasons including updates applied or any additional software installed.

PeterDavidMendez wrote Oct 10 at 7:31 PM

I have this same issue. I've run the same script before an completed successfully. I'm trying to install Project Serve 2013 at the same time. The SQL instance does have another SP2013 farm on it. I've made sure the database names are very different. This is a new install, so I don't think running "psconfig -cmd upgrade -inplace b2b" will do anything.

Any suggestions?

PeterDavidMendez wrote Oct 10 at 11:35 PM

Ok I figured Out my issue. I included the SharePoint 2013 April 2014 CU, but not the Project Server April 2014 CU.

To get around it I uninstalled Project Server and changed the install to false in the autospinstaller-serverconfig.xml. The SharePoint 2013 install is working fine now.

I'll add Project Server on after when I get the April CU downloaded. What I'll actually do is download the Sept. 2014 CU and start from there.