Script Halts at creating the first web application

Topics: Support
Oct 20, 2015 at 9:05 PM
My script keeps halting at creating the first web application.
The error I get (below) doesnt make sense to me - the part that says (WARNING: Could not create local user profile for island\spsvcaps_qa) as this is my service app pool account and nothing i read anywhere states that this requires interaction.

Here is what is output.

  • Adding Managed Accounts...
    • Account "island\spsvcaps_qa:
    • Creating local profile for island\spsvcaps_qa...
      Start-Process : This command cannot be run due to the error: Logon failure: the user has not been granted the
      requested logon type at this computer.
      At D:\Temp\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:2091 char:17
  • Start-Process -WorkingDirectory "$env:SYSTEMROOT\System32\" -Fil ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : InvalidOperation: (:) [Start-Process], InvalidOperationException
    • FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.Commands.StartProcessCommand
.
WARNING: Could not create local user profile for island\spsvcaps_qa

- Done Adding Managed Accounts.


  • Creating web applications...

- Creating Web App "EMPCS-SHAREPOINTDEV"

  • Script halted!
Exception : Microsoft.SharePoint.PowerShell.SPCmdletException: ApplicationPoolAccount is not found.
                       at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord
                    errorRecord)
TargetObject : Microsoft.SharePoint.PowerShell.SPCmdletNewSPWebApplication
CategoryInfo : InvalidArgument: (Microsoft.Share...PWebApplication:SPCmdletNewSPWebApplication)
                    [New-SPWebApplication], SPCmdletException
FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPWebApplication
ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
ScriptStackTrace : at CreateWebApp, D:\Temp\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1: line 2679
                    at CreateWebApplications, D:\Temp\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1: line 2575
                    at Setup-Farm, D:\Temp\SP\AutoSPInstaller\AutoSPInstallerMain.ps1: line 209
                    at <ScriptBlock>, D:\Temp\SP\AutoSPInstaller\AutoSPInstallerMain.ps1: line 408
                    at <ScriptBlock>, <No file>: line 1
PipelineIterationInfo : {}

PSMessageDetails :

| Automated SP2013 install script |
| Started on: 10/20/2015 4:00:46 PM |

| Aborted: 10/20/2015 4:02:48 PM |

PS C:\Users\spadmin_qa\Desktop> EMPCS-SHAREPOINTDEV