SP2013 April 2015 CU and dependancy issues on SP1

Topics: Feedback
Apr 22, 2015 at 10:06 PM
You've probably seen by now the issue of getting the right SP1 before you can apply the April 2015 CU. List of “Good” SharePoint 2013 Service Pack 1 Packages

I use AutoSPInstaller to do my builds. My first attempt at using the April 2015 CU failed with a build dependany failure (as predicted).

In the end I refreshed my install media with the MSDN “SP2013 with SP1″ [which is “broke”] and then extracted the SP1 patch into the \SharePoint\Updates\ folder on my media. Then added the April 2015 CU to the (AutoSPInstaller) \Updates\ folder.

This worked like a charm. Though it does mean my install media is now ~7Gig

Hopefully that helps some people.
Marked as answer by brianlala on 6/17/2015 at 8:37 PM