Cannot Locate SP Binaries - Cannot determine version of SharePoint setup binaries, and no Version was specific in xml

Topics: General Questions, Support
Feb 25, 2015 at 5:48 AM
Edited Feb 25, 2015 at 5:57 AM
Hi Everyone

I am running Windows Server 2012 R2 and am trying to configure four SP servers.

When I run AutoSPInstallerLaunch.bat - I get the error:

WARNING: Cannot locate SharePoint binaries; please check the at the files are in the \SharePoint subfolder as per new folder structure. Enter 'y' to proceed if you know that SharePoint is already installed...

After pressing Y I get:
Cannot determine version of SharePoint setup binaries, and no version was specified in XXX.xml

~ The files are definitely in that location
~ the version is specified in line 28 of the .xml file as
<Install SPVersion="2013">
I should mention that I couldn't figure out this issue so I manually installed the SP and up to Sep 14 CU on all 4 servers but am still getting the same message.

Note: I know that this thread has already been posted here but that did not answer my issue.

Thank you
Feb 25, 2015 at 11:59 AM
Edited Feb 25, 2015 at 12:58 PM
Did you copy the SharePoint binaries in SP\2013\SharePoint from the ISO or just placed the ISO in that location or something else? It should be the first option.
Feb 26, 2015 at 6:51 AM
I mounted the ISO and copied the files to C:\AutoSPInstaller\2013\SharePoint. When I launch the .bat file in powershell I am changing the drive to \SERVERNAME\C$\AutoSPInstaller\2013\SharePoint (as it is for multiple servers).
Feb 26, 2015 at 12:27 PM
And where do you have your XML, .bat and PS1 files?
Feb 27, 2015 at 4:21 AM
My file structure is as follows:


The files you ask about are:
Feb 27, 2015 at 1:36 PM
That should have worked but only from a server with the NETBIOSNAME = SERVERNAME . It does not matter where the files are located, but they have to be run from SERVERNAME.

So, are you running it from a Server with NETBIOSNAME = SERVERNAME? Are you using PSRemoting?
Feb 28, 2015 at 7:30 AM
I am not using PSRemoting, I confirm I am running it from the same server that is on the xml file (I checked with $env:COMPUTERNAME = SERVERNAME).
Apr 14, 2015 at 1:04 AM
Please make sure your XML is good by validating it here (copy/paste):

I bet you $10 you have open or incorrect XML tag.

May 16, 2015 at 6:03 PM
Edited May 16, 2015 at 6:09 PM
Hi Ivan, you are 100% correct. I had this same error and when I opened the configuration file, it was 100% blank. Not sure what happened. It ran and installed most of services but error-ed out. When I launched the build script again, it gave me the same error as reported above. When I looked at the config file, it was empty. restored my Backup and it was fine.

The original config file although it appears empty still has a size however. If you want a copy of teh file jsut shoot me an email to and Ill be happy to provide it
Jun 5, 2015 at 7:36 PM
Edited Jun 5, 2015 at 7:36 PM
Thanks for the tip regarding invalid XML. Turns out I had an ampersand (&) in an auto-generated password.