- Trying to connect to "SQL"... - Fail

Topics: Support
Jul 29, 2014 at 1:39 PM
Servers:
Server 2012 R2 Standard (SharePoint 2013) SPS03P1
Server 2012 R2 Standard (SQL Server 11.0.2100) SPS03PSQL
FS02 (File Server)

Install account SMF\FarmP is local admin on both systems and has the following SQL server roles dbcreator, securityadmin, serveradmin, sysadmin.

I installed SQL server management studio and can connect using windows authentication and create a DB in the named instance.

I currently have the firewalls on both systems off for trouble shooting.

Any help will be appreciated.

Windows PowerShell transcript start
Start time: 20140729064450
Username : SMF\FarmP
Machine : SPS03P1 (Microsoft Windows NT 6.3.9600.0)

Transcript started, output file is C:\Users\FarmP\Desktop\AutoSPInstaller-2014-07-29_6-44.rtf

| Automated SP2013 install script |

| Started on: 7/29/2014 6:44:50 AM |

  • SharePoint 2013 binaries are not yet installed.
  • Install based on:
    • \fs02\IT_Bureau\Software\Microsoft\Sharepoint\CodePlex\AutoSPInstaller\SP\AutoSPInstaller\AutoSPInstallerProduction.xml
    • Environment: Production

- Version: 3.96

  • Validating user accounts and passwords...
  • Account "SMF\FarmP" (Account)...Verified.
  • Account "SMF\ServicesP" (ManagedAccount)...Verified.
  • Account "SMF\PortalP" (ManagedAccount)...Verified.
  • Account "SMF\ProfilesP" (ManagedAccount)...Verified.
  • Account "SMF\FarmP" (ManagedAccount)...Verified.
  • Account "SMF\SuperUserP" (ManagedAccount)...Verified.
  • Account "SMF\SuperReaderP" (ManagedAccount)...Verified.
  • Account "SMF\SearchSerP" (ManagedAccount)...Verified.
  • Account "SMF\SearchConP" (ManagedAccount)...Verified.
  • Account "SMF\ExcelP" (ManagedAccount)...Verified.
  • Account "SMF\VisioP" (ManagedAccount)...Verified.
  • Account "SMF\PerfpP" (ManagedAccount)...Verified.
  • Account "SMF\ProSyncP" (ManagedAccount)...Verified.
  • Account "SMF\ProSyncP" (User Profile Service Application)...Verified.
  • Account "SMF\SearchSerP" (Search Service Application)...Verified.
  • Account "SMF\ExcelP" (Excel Services Application)...Verified.
  • Account "SMF\VisioP" (Visio Graphics Service)...Verified.
  • Account "SMF\PerfpP" (PerformancePoint Service)...Verified.
  • Account "SMF\SuperUserP"...Verified.
  • Account "SMF\SuperReaderP"...Verified.

- Account "SMF\FarmP"...Verified.

- Writing config-AutoSPInstaller.xml to C:\Users\FarmP\AppData\Local\Temp...

  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Creating SQL alias "SPS03PSQL\Production,1433"...
  • Testing access to SQL server/instance/alias: SPS03PSQL\Production

- Trying to connect to "SPS03PSQL\Production"... - Fail

  • Script halted!
  • Connection Error. Check server name, port, firewall.

Press any key to exit...

| Automated SP2013 install script |
| Started on: 7/29/2014 6:44:50 AM |

| Aborted: 7/29/2014 7:04:14 AM |

PS C:\Windows>
Coordinator
Jul 29, 2014 at 2:32 PM
It looks like you may have specified your alias(es) incorrectly... Also, why are you creating so many of them? You don't need to specify database info for every service app if they are all using the same instance & alias. Finally, the alias should not have any port information in it. Maybe you're putting the alias where the instance should be?

HTH,
Brian
Marked as answer by MJN on 7/29/2014 at 10:03 AM
Jul 29, 2014 at 5:04 PM
I unchecked the box for all the alias's and changed the server name to just SPS03PSQL.