Exception after Step "Done applying object cache accounts to"

Topics: Feedback, General Questions, Support
Jul 9 at 1:07 PM
Edited Jul 9 at 2:09 PM
Hi all,

i run today the first time AutoSPInstaller using the version from July 7 2014. I setup a SharePoint 2010 SP2 on a Windows Server 2012. The script runs into a exception (see log below) but the central admin is up. Was the installtion successful or was anything not installed?

Greetings,
Kangee
--------------------------------------------------------------
 - Creating web applications...
 - Skipping setting the web app directory path name (not currently working on Windows 2012 w/SP2010)...
 - Creating Web App "Portal"
 - Setting up managed paths for "http://sharepoint-vm:80"
  - Setting up explicit managed path "help" at "http://sharepoint-vm:80" and HNSCs...
 - Done setting up managed paths at "http://sharepoint-vm:80"
 - Granting domain\sharepointservices rights to "Portal"...Done.
 - Granting i:0#.w|domain\sharepointdb Full Control to http://sharepoint-vm/...
--------------------------------------------------------------
 - Applying object cache accounts to "http://sharepoint-vm:80"...
 - Granting i:0#.w|domain\sharepointservices Full Control to http://sharepoint-vm/...
 - Granting i:0#.w|domain\sharepointservices Full Read to http://sharepoint-vm/...
 - Done applying object cache accounts to "http://sharepoint-vm:80"
--------------------------------------------------------------
 - Script halted!


Exception             : System.Management.Automation.RuntimeException: Method invocation failed because [System.String]
                         doesn't contain a method named 'SelectSingleNode'.
                           bei System.Management.Automation.ParserOps.CallMethod(Token token, Object target, String met
                        hodName, Object[] paramArray, Boolean callStatic, Object valueToSet)
                           bei System.Management.Automation.MethodCallNode.InvokeMethod(Object target, Object[] argumen
                        ts, Object value)
                           bei System.Management.Automation.MethodCallNode.Execute(Array input, Pipe outputPipe, Execut
                        ionContext context)
                           bei System.Management.Automation.ifStatementNode.Execute(Array input, Pipe outputPipe, Array
                        List& resultList, ExecutionContext context)
                           bei System.Management.Automation.StatementListNode.ExecuteStatement(ParseTreeNode statement,
                         Array input, Pipe outputPipe, ArrayList& resultList, ExecutionContext context)
TargetObject          : SelectSingleNode
CategoryInfo          : InvalidOperation: (SelectSingleNode:String) [], RuntimeException
FullyQualifiedErrorId : MethodNotFound
ErrorDetails          :
InvocationInfo        : System.Management.Automation.InvocationInfo
PipelineIterationInfo : {}
PSMessageDetails      :
Jul 9 at 1:16 PM
Do you mean July 7th 2014 version?
Jul 9 at 2:09 PM
Yes i mean july 7th 2014 (i will fix it in my opening post)
Jul 11 at 10:15 AM
Most service applications were not installed. does it make sense to install these service applications by hand or should I wait for a new version of spautoinstallen?
Jul 11 at 4:50 PM
Can you post your XML, looks like youre missing something.
Jul 11 at 4:53 PM
Looks like you have the same problem as https://autospinstaller.codeplex.com/workitem/21106
Jul 14 at 9:16 AM
Thank you for your reply Ivan.

You find my AutoInstallerInput.xml here:

https://drive.google.com/file/d/0B_CYfx5e0m0rUk4yOVI2N1lmY1k/edit?usp=sharing
Jul 14 at 2:42 PM
As Ivan correctly mentioned. You need to populate sitecollections nodes. Compare your XML with the original.
Jul 14 at 3:12 PM
Edited Jul 14 at 3:15 PM
Hi all,

i update the AutoSPInstallerFunctions.ps1 as described in https://autospinstaller.codeplex.com/workitem/21106
The error no longer occurs but now the scriptend with this error:
 - Granting rights to Metadata Service Application:
  - domain\sharepointservices...
Grant-SPObjectSecurity : The pipeline has been stopped.
At D:\AutoSPInstaller\SP\AutoSPInstaller\AutoSPInstallerFunctions.ps1:2386 char:43
+                     Grant-SPObjectSecurity <<<<  $metadataServiceAppSecurity -Principal $accountPrincipal -Rights "Fu
ll Access to Term Store"
    + CategoryInfo          : InvalidData: (Microsoft.Share...tObjectSecurity:SPCmdletGrantObjectSecurity) [Grant-SPOb
   jectSecurity], PipelineStoppedException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGrantObjectSecurity

Grant-SPObjectSecurity: The argument "Rights" is not valid
Jul 15 at 3:47 PM
Edited Jul 15 at 3:49 PM