Installing SP2010 - Script halted!

Topics: Support
Nov 8, 2013 at 7:07 PM
Hi, I am having an issue with the script halting at installing SP2010. I have redone the input file several times both manually and from autospinstallergui and it gets to the same place each time and aborts. I used the pre-requisite utility to download those files and also tried the script by setting offline to false. I have used my service accounts and also the 4 managed accounts that were in the autospinstallergui by default. So far I am unable to get past this point.

Windows PowerShell Transcript Start
Start time: 20131108135640
Username : CHOA\moss_trn_admn
Machine : DCVW-SPTR-APP01 (Microsoft Windows NT 6.1.7601 Service Pack 1)

Transcript started, output file is C:\Users\moss_trn_admn\Desktop\AutoSPInstaller-2013-11-08_1-56.r

tf

| Automated SP2010 install script |

| Started on: 11/8/2013 1:56:40 PM |

- SharePoint 2010 binaries are already installed.

  • Validating user accounts and passwords...
  • Account "CHOA\MOSS_TRN_ADMN" (Account)...Verified.
  • Account "CHOA\SP_Services" (ManagedAccount)...Verified.
  • Account "CHOA\SP_PortalAppPool" (ManagedAccount)...Verified.
  • Account "CHOA\SP_ProfilesAppPool" (ManagedAccount)...Verified.
  • Account "CHOA\SP_SearchService" (ManagedAccount)...Verified.
  • Account "CHOA\MOSS_PROFILE_SYNC" (User Profile Service Application)...Verified.
  • Account "DOMAIN\SP_SearchService" (EnterpriseSearchService)...Verified.
  • Account "CHOA\MOSS_SRCH_CONT_SRVC" (Search Service Application)...Verified.
  • Account "CHOA\SP_SearchService" (SharePoint Search Application Pool)...Verified.
  • Account "CHOA\MOSS_SUPER_USR"...Verified.
  • Account "CHOA\MOSS_SUPER_READER"...Verified.
  • Account "DOMAIN\SP_PortalAppPool"...Verified.

- Account "DOMAIN\SP_ProfilesAppPool"...Verified.

- Writing config-AutoSPInstaller.xml to C:\Users\moss_trn_admn\AppData\Local\Temp\2...

  • Creating SQL alias "SP-Training"...
  • Testing access to SQL server/instance/alias: SP-Training
  • Trying to connect to "SP-Training"...Success
  • SQL Server version is: 10.50.4290.0
  • This instance of SQL Server is not clustered
  • Check if CHOA\moss_trn_admn has dbcreator server role...Pass

- Check if CHOA\moss_trn_admn has securityadmin server role...Pass

  • Install based on:
    • C:\SP2010\AutoSPInstaller\DCVWSPTRAPP01M.xml
    • Environment: Training

- Version: 3.93

- Disabling Loopback Check...


- Disabling IE Enhanced Security...


  • Setting services Spooler, AudioSrv and TabletInputService to Manual...
  • Spooler is already stopped and set Manual, no action required.
  • AudioSrv is already stopped and set Manual, no action required.
  • TabletInputService is already stopped and set Manual, no action required.
  • Setting unused services WerSvc to Disabled...
  • WerSvc is already stopped and disabled, no action required.

- Finished disabling services.


- Not changing CRL check behavior.


- SharePoint 2010 prerequisites appear be already installed - skipping install.


  • Configuring IIS logging...

- H:\IISLogs is already compressed.


- SharePoint 2010 binaries appear to be already installed - skipping installation.


  • Installing SharePoint Language Packs:
  • Installing ServerLanguagePack_SP2_en-us.exe...........Done.
  • Language pack ServerLanguagePack_SP2_en-us.exe setup completed in 00:00:40.
  • No Language Pack service packs found.
  • Language Pack installation complete.
  • Currently installed languages:

- English (United States)


  • Looking for SharePoint updates to install...
    • Installing SP2010 Service Pack 2 oserversp2010-kb2687453-fullfile-x64-en-us.exe....Done.
    • Patch not required; installed product is same or newer.
    • Service Pack 2 install completed in 00:00:05.
    • Installing SP2010 ...--------------------------------------------------------------
  • Script halted!
Exception : System.Management.Automation.ParameterBindingValidationException: Cannot va
                    lidate argument on parameter 'Name'. The argument is null or empty. Supply 
                    an argument that is not null or empty and then try the command again. ---> 
                    System.Management.Automation.ValidationMetadataException: The argument is n
                    ull or empty. Supply an argument that is not null or empty and then try the
                     command again.
                       at System.Management.Automation.ValidateNotNullOrEmptyAttribute.Validate
                    (Object arguments, EngineIntrinsics engineIntrinsics)
                       at System.Management.Automation.ParameterBinderBase.BindParameter(Comman
                    dParameterInternal parameter, CompiledCommandParameter parameterMetadata, P
                    arameterBindingFlags flags)
                       --- End of inner exception stack trace ---
                       at System.Management.Automation.ParameterBinderBase.BindParameter(Comman
                    dParameterInternal parameter, CompiledCommandParameter parameterMetadata, P
                    arameterBindingFlags flags)
                       at System.Management.Automation.CmdletParameterBinderController.BindPara
                    meter(CommandParameterInternal argument, MergedCompiledCommandParameter par
                    ameter, ParameterBindingFlags flags)
                       at System.Management.Automation.CmdletParameterBinderController.BindPara
                    meter(UInt32 parameterSets, CommandParameterInternal argument, MergedCompil
                    edCommandParameter parameter, ParameterBindingFlags flags)
                       at System.Management.Automation.CmdletParameterBinderController.BindPara
                    meters(UInt32 parameterSets, Collection`1 arguments, CommandMetadata comman
                    dMetadata)
                       at System.Management.Automation.CmdletParameterBinderController.BindComm
                    andLineParametersNoValidation(Collection`1 arguments)
                       at System.Management.Automation.CmdletParameterBinderController.BindComm
                    andLineParameters(Collection`1 arguments)
                       at System.Management.Automation.CommandProcessor.BindCommandLineParamete
                    rs(CommandParameterInternal[] parameters)
                       at System.Management.Automation.CommandProcessor.Prepare(CommandParamete
                    rInternal[] parameters)
                       at System.Management.Automation.CommandProcessorBase.DoPrepare(CommandPa
                    rameterInternal[] parameters)
                       at System.Management.Automation.Internal.PipelineProcessor.Start(Boolean
                     incomingStream)
                       at System.Management.Automation.Internal.PipelineProcessor.SynchronousEx
                    ecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
TargetObject :
CategoryInfo : InvalidData: (:) [Get-Process], ParameterBindingValidationException
FullyQualifiedErrorId : ParameterArgumentValidationError,Microsoft.PowerShell.Commands.GetProcessCo
                    mmand
ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
PipelineIterationInfo : {}

PSMessageDetails :

| Automated SP2010 install script |
| Started on: 11/8/2013 1:56:40 PM |

| Aborted: 11/8/2013 1:57:28 PM |

PS C:\SP2010\AutoSPInstaller>
Nov 11, 2013 at 6:21 PM
Edited Nov 11, 2013 at 6:40 PM
Ok, I found the cause. I had only downloaded SharePoint2010 SP2 and the latest CU, not SP1 and June 2012 CU

I found this today,

Region Install Update(s)

===================================================================================

Func: InstallUpdates

Desc: Install SharePoint Updates (CUs and Service Packs) to work around slipstreaming issues

===================================================================================

Function InstallUpdates
{
WriteLine
Write-Host -ForegroundColor White " - Looking for SharePoint updates to install..."
$spYears = @{"14" = "2010"; "15" = "2013"}
$spYear = $spYears.$env:spVer
# Result codes below are from http://technet.microsoft.com/en-us/library/cc179058(v=office.14).aspx
$oPatchInstallResultCodes = @{"17301" = "Error: General Detection error";
                              "17302" = "Error: Applying patch";
                              "17303" = "Error: Extracting file";
                              "17021" = "Error: Creating temp folder";
                              "17022" = "Success: Reboot flag set";
                              "17023" = "Error: User cancelled installation";
                              "17024" = "Error: Creating folder failed";
                              "17025" = "Patch already installed";
                              "17026" = "Patch already installed to admin installation";
                              "17027" = "Installation source requires full file update";
                              "17028" = "No product installed for contained patch";
                              "17029" = "Patch failed to install";
                              "17030" = "Detection: Invalid CIF format";
                              "17031" = "Detection: Invalid baseline";
                              "17034" = "Error: Required patch does not apply to the machine";
                              "17038" = "You do not have sufficient privileges to complete this installation for all users of the machine. Log on as administrator and then retry this installation";
                              "17044" = "Installer was unable to run detection for this package"}
if ($spYear -eq "2010")
{
    $sp2010SP1 = Get-ChildItem "$bits\$spYear\Updates" -Name -Include "officeserver2010sp1-kb2460045-x64-fullfile-en-us.exe" -ErrorAction SilentlyContinue
    ##$sp2010June2012CU = Get-ChildItem "$bits\$spYear\Updates" -Name -Include "office2010-kb2598354-fullfile-x64-glb.exe" -ErrorAction SilentlyContinue
    $sp2010June2013CU = Get-ChildItem "$bits\$spYear\Updates" -Name -Include "ubersrv2010-kb2817527-fullfile-x64-glb.exe" -ErrorAction SilentlyContinue
    $sp2010SP2 = Get-ChildItem "$bits\$spYear\Updates" -Name -Include "oserversp2010-kb2687453-fullfile-x64-en-us.exe" -ErrorAction SilentlyContinue
    # First & foremost, install SP2 if it's there
    if ($sp2010SP2)
    {
        InstallSpecifiedUpdate $sp2010SP2 "Service Pack 2"
        # Now install any language pack service packs that are found, using the naming convention for SP2
        $sp2010LPServicePacks = Get-ChildItem "$bits\$spYear\Updates" -Name -Include oslpksp2010*.exe -ErrorAction SilentlyContinue | Sort-Object -Descending
        foreach ($sp2010LPServicePack in $sp2010LPServicePacks)
        {
            InstallSpecifiedUpdate $sp2010LPServicePack ""
        }
    }
So it was looking for SP1 and the June 2012 CU as well in the script. I downloaded them to the updates folder and reran the installer. It is installing.
Marked as answer by scottpayne on 11/11/2013 at 10:38 AM
Apr 15, 2014 at 5:51 PM
Edited Apr 15, 2014 at 6:26 PM
This solution partly worked for me. SP1 worked, but it failed afterwards. Having June 2012 CU in the folder didn't help. Adding June 2011, in case "2012" was a typo, didn't help either. I ended up commenting out InstallUpdates in AutoSpInstallerMain.ps1