Error with User Profile Service Application

Oct 15, 2013 at 11:52 AM
While running script AutoSPInstaller 2010, I am getting the following errors:
  • Updating User Profile Synchronization Service to run as DOMAIN\user...
    • Waiting for User Profile Synchronization Service...Exception calling "SetSynchronizationMachine" with "4" argument(s): "Operation
      is not valid due to the current state of the object."
      At D:\SP2010\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1974 char:50
  • $ProfileServiceApp.SetSynchronizationMachine <<<< ($env:C
    OMPUTERNAME, $ProfileSyncService.Id, $FarmAcct, (ConvertTo-PlainText $FarmAcctP
    WD))
    • CategoryInfo : NotSpecified: (:) [], MethodInvocationException
    • FullyQualifiedErrorId : DotNetMethodException

  • Script aborted!

- Error Provisioning the User Profile Service Application

Please help to find a solution
Oct 16, 2013 at 3:31 AM
Please have a look here - http://www.harbar.net/articles/sp2010ups.aspx

You need to meet all the pre-reqs for the User Profile Service + Sync Service, otherwise it won't start.
Marked as answer by Yusraa on 10/17/2013 at 4:48 AM
Oct 16, 2013 at 8:08 AM
Thanks Mongey.

I went through the link and managed to start user profile service + sync service.

am I supposed to run the AutoSPInstaller script again or I can set the rest of the script manually??
Oct 16, 2013 at 11:06 PM
AutoSPInstaller can be run over and over again, even after SharePoint has been installed - example, to add in another Service Application. It will detect the User Profile Service has already being provisioned and move to the next part of the script.
Marked as answer by Yusraa on 10/17/2013 at 4:48 AM
Oct 17, 2013 at 11:47 AM
Thank you heaps Mongey. Worked like a charm :)