Getting an error on Office Web Apps updates

Sep 25, 2013 at 3:41 PM
I can't seem to get past this error. My simplistic question: can I just get past the script by removing the Office Web Apps update files?

Full log posted:

Windows PowerShell Transcript Start
Start time: 20130923160542
Username : NWEA\spinstall_w04
Machine : PRC0-WEB2004 (Microsoft Windows NT 6.1.7601 Service Pack 1)

Transcript started, output file is C:\Users\spinstall_w04\Desktop\AutoSPInstall

er-2013-09-23_4-05.rtf

| Automated SP2010 install script |

| Started on: 9/23/2013 4:05:42 PM |

- SharePoint 2010 binaries are not yet installed.

  • Validating user accounts and passwords...
  • Account "NWEA\spfarm_w04" (Account)...Verified.
  • Account "NWEA\svc.spsvc_w04" (ManagedAccount)...Verified.
  • Account "NWEA\svc.spapp_w04" (ManagedAccount)...Verified.
  • Account "NWEA\svc.spcont_w04" (ManagedAccount)...Verified.
  • Account "NWEA\svc.spsrch_w04" (ManagedAccount)...Verified.
  • Account "NWEA\svc.spsrch_w04" (EnterpriseSearchService)...Verified.
  • Account "NWEA\svc.spsrch_w04" (Search Service Application)...Verified.
  • Account "NWEA\svc.spsrch_w04" (SharePoint Search Application Pool)...Verified.
  • Account "NWEA\spfarm_w04" (Excel Web App)...Verified.
  • Account "NWEA\svc.spcont_w04"...Verified.
  • Account "NWEA\svc.spapp_w04"...Verified.

- Account "NWEA\spfarm_w04"...Verified.

  • Writing config-AutoSPInstaller.xml to C:\Users\spinstall_w04\AppData\Local\Temp...
  • Using existing OWA config file:

- D:\SP\AutoSPInstaller\config-OWA-2010.xml

  • Testing access to SQL server/instance/alias: Prc0-sql2001
  • Trying to connect to "Prc0-sql2001"...Success
  • SQL Server version is: 10.50.2789.0
  • This instance of SQL Server is not clustered
  • Check if NWEA\spinstall_w04 has dbcreator server role...Pass

- Check if NWEA\spinstall_w04 has securityadmin server role...Pass

  • Install based on:
    • D:\SP\AutoSPInstaller\AutoSPInstallerInput.xml
    • Environment: Prod

- Version: 1.0

- Disabling Loopback Check...


- Disabling IE Enhanced Security...


  • Setting services Spooler, AudioSrv and TabletInputService to Manual...
  • Service Spooler is now set to Manual start
  • AudioSrv is already stopped and set Manual, no action required.
  • TabletInputService is already stopped and set Manual, no action required.
  • Setting unused services WerSvc to Disabled...
  • WerSvc is already stopped and disabled, no action required.

- Finished disabling services.


- Not changing CRL check behavior.


  • Installing Prerequisite Software:
    • .Net Framework 3.5.1...Done.
    • SQL Native Client...
    • Running Prerequisite Installer (offline mode)......................................Done.
    • Prerequisite Installer completed in 00:02:55.

- All Prerequisite Software installed successfully.


  • Configuring IIS logging...

- C:\Inetpub\logs is already compressed.


  • Installing SharePoint 2010 binaries..........................................................................................Done.
  • SharePoint 2010 setup completed in 00:07:21.
  • Waiting for SharePoint Products and Technologies Wizard to launch...Done.

- Exiting Products and Technologies Wizard - using Powershell instead!


  • Installing Office Web Apps binaries........................................Done.
  • Office Web Apps setup completed in 00:03:05.
  • Waiting for SharePoint Products and Technologies Wizard to launch...Done.

- Exiting Products and Technologies Wizard - using Powershell instead!


  • No language packs found in D:\SP\2010\LanguagePacks, skipping.
  • Currently installed languages:

- English (United States)


  • Looking for SharePoint updates to install...
    • Installing SP2010 Office Web Apps Update ...--------------------------------------------------------------
  • Script halted!
Exception : System.Management.Automation.ParameterBindingValidation
                    Exception: Cannot validate argument on parameter 'Name'
                    . The argument is null or empty. Supply an argument tha
                    t is not null or empty and then try the command again. 
                    ---> System.Management.Automation.ValidationMetadataExc
                    eption: The argument is null or empty. Supply an argume
                    nt that is not null or empty and then try the command a
                    gain.
                       at System.Management.Automation.ValidateNotNullOrEmp
                    tyAttribute.Validate(Object arguments, EngineIntrinsics
                     engineIntrinsics)
                       at System.Management.Automation.ParameterBinderBase.
                    BindParameter(CommandParameterInternal parameter, Compi
                    ledCommandParameter parameterMetadata, ParameterBinding
                    Flags flags)
                       --- End of inner exception stack trace ---
                       at System.Management.Automation.ParameterBinderBase.
                    BindParameter(CommandParameterInternal parameter, Compi
                    ledCommandParameter parameterMetadata, ParameterBinding
                    Flags flags)
                       at System.Management.Automation.CmdletParameterBinde
                    rController.BindParameter(CommandParameterInternal argu
                    ment, MergedCompiledCommandParameter parameter, Paramet
                    erBindingFlags flags)
                       at System.Management.Automation.CmdletParameterBinde
                    rController.BindParameter(UInt32 parameterSets, Command
                    ParameterInternal argument, MergedCompiledCommandParame
                    ter parameter, ParameterBindingFlags flags)
                       at System.Management.Automation.CmdletParameterBinde
                    rController.BindParameters(UInt32 parameterSets, Collec
                    tion`1 arguments, CommandMetadata commandMetadata)
                       at System.Management.Automation.CmdletParameterBinde
                    rController.BindCommandLineParametersNoValidation(Colle
                    ction`1 arguments)
                       at System.Management.Automation.CmdletParameterBinde
                    rController.BindCommandLineParameters(Collection`1 argu
                    ments)
                       at System.Management.Automation.CommandProcessor.Bin
                    dCommandLineParameters(CommandParameterInternal[] param
                    eters)
                       at System.Management.Automation.CommandProcessor.Pre
                    pare(CommandParameterInternal[] parameters)
                       at System.Management.Automation.CommandProcessorBase
                    .DoPrepare(CommandParameterInternal[] parameters)
                       at System.Management.Automation.Internal.PipelinePro
                    cessor.Start(Boolean incomingStream)
                       at System.Management.Automation.Internal.PipelinePro
                    cessor.SynchronousExecuteEnumerate(Object input, Hashta
                    ble errorResults, Boolean enumerate)
TargetObject :
CategoryInfo : InvalidData: (:) [Get-Process], ParameterBindingValidat
                    ionException
FullyQualifiedErrorId : ParameterArgumentValidationError,Microsoft.PowerShell.C
                    ommands.GetProcessCommand
ErrorDetails :
InvocationInfo : System.Management.Automation.InvocationInfo
PipelineIterationInfo : {}

PSMessageDetails :

| Automated SP2010 install script |
| Started on: 9/23/2013 4:05:42 PM |

| Aborted: 9/23/2013 4:20:30 PM |

PS C:\Windows\system32>
Sep 26, 2013 at 4:36 PM
Looks like you didn't specify something in you XML config file or, you have files missing. To answer your question though, yes, you can skip it. Just comment that function out in the AutoSPInstallerMain.ps1 and remember to install the updates manually later.