Problem while installing withnew AutoSpInstaller

Jun 14, 2013 at 7:55 AM
Edited Jun 14, 2013 at 8:20 AM
Hi,

I am currently trying to install with the new AutoSpInstaller version 3.87. With older version I never had to click run when the prerequisites installer of SharePoint setup installer are trying to start. With the new version I get a popu from windows asking me if I would like to run prerequisites installer.exe and SharePoint setup.exe. I disabled UAC and I am local admin on server.

The problem is actually that I get the open file security warning. I never get this on my own server.
Jun 19, 2013 at 12:07 AM
Jun 19, 2013 at 8:48 AM
But the strange thing is that on my server I don't get the message. But I do get it on my customers server.
I can not change the setting there. I am not allowed to do that.
Jul 16, 2013 at 3:18 PM
Edited Jul 16, 2013 at 3:19 PM
Hi Waaromikniet,

My config and binaries are hosted on a central server, using version 3.87 I get the security prompt unless I add low risk files to the VM.

I add a PS method to do the change. In AutoSPInstallerMain.ps1 I add the line of code in this section of code:

If (MatchComputerName $farmServers $env:COMPUTERNAME)
{
__Add-LowRiskFileTypes__
...
I then add the Method to AutoSPInstallerFunctionsCustom.ps1 :

Function Add-LowRiskFileTypes(){
$Lowriskregpath ="HKCU:\Software\Microsoft\Windows\Currentversion\Policies\Associations"
$Lowriskregfile = "LowRiskFileTypes"
$LowRiskFileTypes = ".exe;.msp;.msi;"
New-Item -Path $Lowriskregpath -erroraction silentlycontinue | Out-null
New-ItemProperty $Lowriskregpath -name $Lowriskregfile -value $LowRiskFileTypes -propertyType String -erroraction silentlycontinue | Out-null
Write-Host "Added Low Risk File Types $LowRiskFileTypes"
}