What is the Last Step in ASPI?

Mar 25, 2013 at 6:47 PM
Hi Brian,

I'm wondering what is the last step in ASPI so that I know the installer finished it's job. As I mentioned in my other post "Getting", I was able to run the ASPI successfully up to the step where it restarts the Managed Metadata service and tries to restart the server but fails. I'm not sure why it is failing to re-start as the pre-requisites reboots the server just fine a couple of times.

BTW, the ASPI does create the sites (home & CA) just fine, I can go and test them out. So, I'm not sure what else is left-over that ASPI needs to do.

I need some help on this.

Best Regards
Mar 27, 2013 at 6:18 PM
Anyone?
Apr 2, 2013 at 3:59 PM
Update:

I tried the SharePoint 2010 installation instead of 2013. Installation goes fine until it hits the same spot as for SharePoint 2013. I'm not sure what I am doing wrong here. Could someone please help me so that I can put this to an end. I'm loosing sleep over it :-)

Here is the log file output:

Windows PowerShell Transcript Start
Start time: 20130402080854
Username : CORP\SP_install
Machine : SPS2010 (Microsoft Windows NT 6.1.7601 Service Pack 1)

Transcript started, output file is C:\Users\SP_install\Desktop\AutoSPInstaller-

2013-04-02_8-08.rtf

| Automated SP2010 install script |

| Started on: 4/2/2013 8:08:54 AM |

- SharePoint 2010 binaries are already installed.

  • Validating user accounts and passwords...
  • Account "CORP\SP_Farm"...Verified.
  • Account "CORP\SP_Services"...Verified.
  • Account "CORP\SP_PortalAppPool"...Verified.
  • Account "CORP\SP_ProfilesAppPool"...Verified.
  • Account "CORP\SP_SearchService"...Verified.
  • Account "CORP\SP_SearchService"...Verified.
  • Account "CORP\SP_SearchContent"...Verified.
  • Account "CORP\SP_PortalAppPool"...Verified.
  • Account "CORP\SP_ExcelUser"...Verified.
  • Account "CORP\SP_VisioUser"...Verified.
  • Account "CORP\SP_PerfPointUser"...Verified.

- Account "CORP\SP_ExcelUser"...Verified.

  • Testing access to SQL server/instance/alias: SPS2010.corp.contoso.local
  • Trying to connect to "SPS2010.corp.contoso.local"...Success
  • SQL Server version is: 10.50.1600.1
  • This instance of SQL Server is not clustered
  • Check if CORP\SP_install has dbcreator server role...Pass
  • Check if CORP\SP_install has securityadmin server role...Pass

- Check if CORP\SP_install has sysadmin server role...Pass

  • Install based on:
    • C:\Fileshare\AutoSPInstaller\AutoSPInstaller\AutoSPInstallerInput-SPS2010.xml
    • Environment: Dev

- Version: 3.2

- Disabling Loopback Check...

- Disabling IE Enhanced Security...

  • Setting services Spooler, AudioSrv and TabletInputService to Manual...
  • Spooler is already stopped and set Manual, no action required.
  • AudioSrv is already stopped and set Manual, no action required.
  • TabletInputService is already stopped and set Manual, no action required.
  • Setting unused services WerSvc to Disabled...
  • WerSvc is already stopped and disabled, no action required.

- Finished disabling services.

- Not changing CRL check behavior.

- SharePoint 2010 prerequisites appear be already installed - skipping install.

  • Configuring IIS logging...

- C:\Inetpub\logs is already compressed.

- SharePoint 2010 binaries appear to be already installed - skipping installation.

  • Installing Office Web Apps binaries..............................................Done.
  • Office Web Apps setup completed in 00:03:36.
  • Waiting for SharePoint Products and Technologies Wizard to launch...Done.

- Exiting Products and Technologies Wizard - using Powershell instead!

  • No language packs found in C:\Fileshare\AutoSPInstaller\LanguagePacks, skipping.
  • Currently installed languages:

- English (United States)

  • Renaming TaxonomyPicker.ascx...

- Done.

- SharePoint 2010 binary file installation done!

- Adding CORP\SP_Farm to local Administrators (only for install)...

- Loading SharePoint Powershell Snapin

  • Checking farm membership for SPS2010 in "SP_Config"...
  • Attempting to join farm on "SP_Config"...
  • No existing farm found.
  • Creating config database "SP_Config"...

- Done creating configuration database for farm.

  • Configuring the SharePoint farm/server...
  • Installing Help Collection...
  • Securing Resources...
  • Installing Services...
  • Installing Features...
  • Creating Central Admin site...
  • Waiting for Central Admin site...Online
  • Installing Application Content...
  • Creating Version registry value (workaround for bug in PS-based install)
  • Getting version number... 14.0.0.4762

- Done initial farm/server config.

  • Configuring SharePoint diagnostic (ULS) logging...

- Compressing C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS and subfolders...

  • Configuring Office Web Apps...
  • Installing Help Collection...
  • Installing Application Content...
  • Securing Resources...
  • Installing Services...

- Installing Features...

  • Adding Managed Accounts
  • Enabling Secondary Logon service...
  • Starting Secondary Logon service...
  • Creating local profile for CORP\SP_Services...Done.
  • Registering managed account CORP\SP_Services...
  • Creating local profile for CORP\SP_PortalAppPool...Done.
  • Registering managed account CORP\SP_PortalAppPool...
  • Creating local profile for CORP\SP_ProfilesAppPool...Done.
  • Registering managed account CORP\SP_ProfilesAppPool...
  • Creating local profile for CORP\SP_SearchService...Done.
  • Registering managed account CORP\SP_SearchService...

- Done Adding Managed Accounts

  • Creating web applications...
  • Creating Web App "Portal"
  • Setting up managed paths for "http://SPS2010:80"
  • Setting up explicit managed path "help" at "http://SPS2010:80"
  • Done setting up managed paths at "http://SPS2010:80"
  • Granting CORP\SP_Services rights to "Portal"...Done.
  • Creating Site Collection "http://SPS2010"...
  • Updating the locale for "Portal Home" to "en-us"...

- Updating 24 hour time format for "Portal Home" to "false"...

  • Applying object cache accounts to "http://SPS2010:80"...
  • Done applying object cache accounts to "http://SPS2010:80"

- Setting online webpart catalog access for "http://SPS2010:80"

  • Creating Web App "MySite Host"
  • Setting up managed paths for "http://SPS2010:8080"
  • Setting up managed path "personal" at "http://SPS2010:8080"
  • Done setting up managed paths at "http://SPS2010:8080"
  • Granting CORP\SP_Services rights to "MySite Host"...Done.
  • Creating Site Collection "http://SPS2010:8080"...
  • Setting the Portal Site Connection for "My Site Host"...
  • Updating the locale for "My Site Host" to "en-us"...

- Updating 24 hour time format for "My Site Host" to "false"...

  • Applying object cache accounts to "http://SPS2010:8080"...
  • Done applying object cache accounts to "http://SPS2010:8080"

- Setting online webpart catalog access for "http://SPS2010:8080"

  • Adding HOSTS file entries for local resolution...
  • Backing up HOSTS file to:
  • C:\Windows\System32\drivers\etc\HOSTS.130402083137.copy

- Adding HOSTS file entry for "sps2010"...

  • Provisioning State Service Application...
  • Creating State Service Application Proxy...

- Done creating State Service Application.

  • Provisioning Managed Metadata Service Application
  • Creating SharePoint Hosted Services Application Pool...
  • Starting Managed Metadata Service:
  • Managed Metadata Service already started.
  • Creating Metadata Service Application...
  • Creating Metadata Service Application Proxy...
  • Granting rights to Metadata Service Application...

- Done creating Managed Metadata Service Application.

- Starting ...

  • Script halted!
  • An error occurred starting

Press any key to exit...

| Automated SP2010 install script |
| Started on: 4/2/2013 8:08:54 AM |

| Aborted: 4/2/2013 8:35:21 AM |

Press any key to exit...
PS C:\Fileshare\AutoSPInstaller\AutoSPInstaller>
Apr 2, 2013 at 4:22 PM
Edited Apr 2, 2013 at 4:23 PM
If I have to guess, then I think you haven't created the My Sites Host Web Application and the Script is failing during the provisioning of User Profile Service Application. In short, you need the My sites host Web App, if you are provisioning UPA.
Apr 2, 2013 at 4:32 PM
Edited Apr 2, 2013 at 6:00 PM
Thanks for the quick reply. in the CA, I see that "MySite Host" Web Application has been created at https://sps2010:8080. However, I can't access it via the browser due to an error "Could not load user profile". I did grant SP_ProfileSync the "Replicate Directory Change" permission on the domain.

I guess the User Profile Application is not provisioned which is the next step after "Done creating Managed Metadata Service Application".

Following instructions at:

http://blog.bugrapostaci.com/2011/04/27/checking-replication-directory-changes-for-account-by-powershell/

I checked the SP_ProfileSync account has permissions at the Domain Level and also at the cn=configuration level to "Replicate Directory Changes".

Any thoughts?
Apr 2, 2013 at 7:12 PM
That is normal behavior. The UPA needs the My Site Host Web Application setup but the My sites host will not work (really function) till the UPA is provisioned. It will be helpful if you can share your sanitized XML Input file.
Apr 2, 2013 at 7:18 PM
Joseph - the blog doesn't allow me to paste anything that is >1K characters. Is ther another way to send you the input file?
Apr 2, 2013 at 7:55 PM
If you want to understand the code sequence, then look at AutoSPInstallerMain.ps1

in the function Setup-Services

The functions being called are:
StartSandboxedCodeService $xmlinput
CreateStateServiceApp $xmlinput
CreateMetadataServiceApp $xmlinput
StartClaimsToWindowsTokenService $xmlinput
CreateUserProfileServiceApplication $xmlinput
So, you could be either failing on Claims to Windows Token Service or on Creating User Profiles.
Apr 2, 2013 at 8:32 PM
The Claims to Windows Token Service wasn't started, I started it manually and re-ran the script but it failed again at the same old spot. Last message I see is "Starting..." and then it dies.
Apr 3, 2013 at 8:36 PM
I've tried almost all the options to make it a success without any luck. The AutoAPInstaller script is failing constantly at the same step as mentioned above. Tried to look at the AutoSPInstallerMain.ps1 and tried to align my steps and did some debugging but no luck.

Here are the steps I've taken on an All-In-One VM:
  1. Installed Win2K8R2 applied all the required KBs as per the article
  2. Promoted the server to be an AD-DC
  3. Created all the required accounts
  4. Granted "Replicate Directory Changes" permissions to SP_ProfileSync (and just in case to SP_Farm)
  5. Installed SQL 2K8R2 and applied SP2
  6. Used AutoSPInstallerGUI to create the XML input file
  7. Ran the installer
  8. Failure :-(
I've spent enough hours on this to make it work but all efforts have gone south.

Is there anyone in the group who can literally help me get this going please?
Apr 3, 2013 at 9:16 PM
SharePointing wrote:
  1. Used AutoSPInstallerGUI to create the XML input file
It seems like maybe your unknown might be the use of the AutoSPInstallerGUI. I know when I looked at using it - it seemed like you needed to be in sync with the versions and it wasn't. Maybe you should try a completely generic input script - from the project - with minimal and manual edits made to at least get the thing going. I have done that when I couldn't figure out what was going on and it helped.
Apr 3, 2013 at 11:06 PM
The current version of AutoSPInstallerGUI (0.0.0.11) works with version 3.2 of AutoSPInstaller that is the one at http://autospinstaller.codeplex.com/SourceControl/changeset/96612
Apr 3, 2013 at 11:25 PM
I'm using exactly these versions of the two products.
Apr 4, 2013 at 12:45 AM
Did you turn off UAC?
Can you comment out the function call to provision UPA, i.e. CreateUserProfileServiceApplication
Apr 4, 2013 at 12:51 AM
Yes, the UAC is turned off.
I will now try with UPA provisioning turned off.
Apr 4, 2013 at 12:56 AM
If it works (and I think it will), make sure that Secondary Logon service is enabled and started.
Apr 4, 2013 at 1:08 PM
Problem solved, many thanks to Joseph for his professional help and support. Here are the takeaways from this post:
  1. Auto Admin Logon switched to Disabled since it is required for SharePoint 2013 and I was doing 2010 install.
  2. Farm Database switched to just the server name (sps2010) rather a FQDN (sps2010.corp.contoso.local).
  3. Also created an Alias (sps2010) for the farm database.
  4. Entered explicit Logging locations as C:\Logs\IIS, C:\Logs\ULS, C:\Logs\Usage, I originally had left them blank.
  5. Outgoing Email wasn't configured because I did not have an SMTP server installed but it looks like this information is required to be there.
  6. For Service Applications, User Profile Service, I had the "Create Default Sync Connection" checked but it isn't supported for On-Premise installations, so it has to be turned off.
  7. Word Automation service application was turned off.
That's it, after changing these things ran the ASPI and installation went just fine. The install was done on a Single (All-In-One) virtual server that contains Windows 2008 R2, AD-DC, SQL2008R2 SP2, and SharePoint 2010.

Next step, I will try to install SharePoint 2013 using the ASPI :-)

Once again thanks a ton to everyone who replied to my frustrated posts and kept up with me specially Joseph for his help and Brian for building such a great tool.

Happy scripting folks!!!