Install of SP2013 failing...

Feb 4, 2013 at 3:26 PM

I'm trying to install SP2013 using the AutoSPInstaller script, but it keeps failing during the prerequisite section:
WARNING: 2013-02-04 16:11:47 - Error: The tool was unable to install Application Server Role, Web Server (IIS) Role.
WARNING: 2013-02-04 16:11:47 - Last return code (OX41D=1053).
It's being run on a Win2K8 server, that is being hosted in Hyper-V, on a Win8 laptop - there is also a DC server and an SQL Server; the latter 2 are running, but I do not have a remote desktop session open to them.

I am unable to get it to continue past this error? It seems to be around where the WinAppFabric download and install has to happen - I've tried downloading it manually and completing the install offline manually, as well as online, but that keeps on failing. I've also tried running the prerequisites.exe setup separately to see if I can at least complete this stage - this has produced the same results. I've also tried resetting ASP.NET to version 4 (using the re-register command) - this has not helped. I've also tried setting up the role types on the server manually, but to no effect.

I know that the script isn't perfect for SP2013 yet, but should be enough to get a working installation - anyone any ideas please? I've spent 3 days on it so far, and am losing faith... :-(
Feb 5, 2013 at 3:19 PM
Since you've already (correctly) determined that the script isn't the problem, you'll have to troubleshoot your server. In these cases, I usually bring up a new server. I found this thread that has some suggestions:
Feb 6, 2013 at 1:07 AM
@alibby251, does your server have outbound Internet access? There are some parts of the prerequisiteinstaller that try to check CRLs for signed code and if they can't connect to the Internet, they may fail.

Like Wahid says, no need to lose faith in the script if you've already determined it's not the source of the problem :-|

Feb 8, 2013 at 7:16 AM

Unfortunately I've had to give up on using AutoSPInstaller, at least for now - there are simply too many challenges in our environment for me to be able to use it, until I can get these challenges resolved first.

Thanks for your help though!

Jan 5, 2015 at 4:45 PM

In the event that this may help somebody else out. If you are trying to use Windows Server 2012 R2, it may not be clear that you need to use the SharePoint Server 2013 SP1 install bits (specfically for the updated prerequisites installer). Since I have existing 2013 farms, I tried to build a Development environment in Azure and I tried to use my slipstreamed installer bits which weren't SP1.

Feb 19, 2015 at 9:30 PM
Edited Feb 19, 2015 at 9:35 PM

How or where can we get the Install bits for SharePoint 2013 with SP1? I have access to install bits of sharepoint from MSDN, and i can also download SP1 for SharePoint but i am unaware of where to get a combined bits?

Can you help?


----------------------------- UPDATE ---------------
i did find them on MDSN

THank you Cory for explaining, although it did take me a few times re-reading it to understand what you meant.