This project has moved and is read-only. For the latest updates, please go here.

AutoSPInstaller for SharePoint 2013 relase date

Jan 21, 2013 at 10:19 PM

I have tried the most recent download on my SharePoint 2013 farm deployment. My environment includes the following,

WFE: Windows 2008 R2 + SP1

SQL: SQL Server 2008 R2 + SP1

I have found multiple bugs using AutoSPInstaller (beta version) to do the SharePoint 2013 deployment, and have not successfully installed SPS 2013 yet.

Any planned release date of AutoSPInstaller for SharePoint server 2013?

Thanks in advance,



Jan 22, 2013 at 2:40 AM

Would you care to provide details on what some of those bugs are? The script certainly isn't perfect or complete yet for SP2013, but plenty of folks have installed it successfully with the recent releases.


Jan 22, 2013 at 1:16 PM

the first error I got is during the prerequest install, the error is as follows,

error when enabling v4.0.30319

I googled on internet most of this error happened on windows server 2012, while I am working on windows server 2008 R2 + sp1

Any thought on this one?


Jan 23, 2013 at 4:02 PM

I got the error when enabling v4.0.30319 fixed.

In case someone run into the same issue, here is the solution working in my case

Hope it helps


Jan 23, 2013 at 4:10 PM
Edited Jan 23, 2013 at 4:22 PM

Now I have SharePoint 2013 installed, and three databases (AdminContent, Config, and PortalContent) are created through the AutoSPInstaller script, added all managed accounts, but it failed when creating site collection, the error message is as follows,

 - Creating web applications...
 - Web app "Portal" already provisioned.
 - Creating Site Collection "http://USNJ01DEV124"...
 - Script halted!

Exception      : Microsoft.SharePoint.SPException: User cannot be found.
                           at Microsoft.SharePoint.Administration.SPSiteCollect
                        ion.Add(SPContentDatabase database, SPSiteSubscription
                        siteSubscription, String siteUrl, String title, String
                        description, UInt32 nLCID, Int32 compatibilityLevel,
                        String webTemplate, String ownerLogin, String
                        ownerName, String ownerEmail, String
                        secondaryContactLogin, String secondaryContactName,
                        String secondaryContactEmail, String quotaTemplate,
                        String sscRootWebUrl, Boolean useHostHeaderAsSiteName,
                        Boolean overrideCompatibilityRestriction)
                           at Microsoft.SharePoint.PowerShell.SPCmdletNewSite.C
                           at Microsoft.SharePoint.PowerShell.SPNewCmdletBase`1
                           at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessR
TargetObject  : Microsoft.SharePoint.PowerShell.SPCmdletNewSite
CategoryInfo  : InvalidData:
                        [New-SPSite], SPException
FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSite
ErrorDetails     :
InvocationInfo : System.Management.Automation.InvocationInfo
ScriptStackTrace      : at CreateWebApp, C:\sp2013installer\SP2013\AutoSPInstal
                        ler\AutoSPInstallerFunctions.ps1: line 1858
                        at CreateWebApplications, C:\sp2013installer\SP2013\Aut
                        oSPInstaller\AutoSPInstallerFunctions.ps1: line 1733
                        at Setup-Farm, C:\sp2013installer\SP2013\AutoSPInstalle
                        r\AutoSPInstallerMain.ps1: line 159
                        at <ScriptBlock>, C:\sp2013installer\SP2013\AutoSPInsta
                        ller\AutoSPInstallerMain.ps1: line 321
                        at <ScriptBlock>, <No file>: line 1
PipelineIterationInfo : {}
PSMessageDetails      :

The script can create web application, that seems to me that the user has permission to SQL, should have the permission to create site collection as well.  Any one had this issue? Any help is appreciate!

Jan 23, 2013 at 4:29 PM

would you mind sharing your config? Looks like you did not configure all required fields to the end.


Jan 23, 2013 at 8:18 PM
Edited Apr 9, 2013 at 5:13 PM
Thanks larbre! You are right.  I found something wrong in my xml configuration file. Now the error is gone. Now I have a new error which I believe the last one, hope you can help. This error happened in ConfigureDistributedCacheService function related with AppFabricCachingService   - Creating Web App "MySite Host" -------------------------------------------------------------- - Provisioning Subscription Settings Service... - Checking Microsoft SharePoint Foundation Subscription Settings Service instance... - Starting Microsoft SharePoint Foundation Subscription Settings Service instance... - Waiting for Microsoft SharePoint Foundation Subscription Settings Service instance...Online - Creating Subscription Settings Service... - Provisioning Subscription Settings Service Proxy... - Done provisioning Subscription Settings Service. - Setting Site Subscription name "app"... -------------------------------------------------------------- -------------------------------------------------------------- - Applying service account ad\xxxxxxxxx to service AppFabricCachingService... - Updating service account... Exception calling "Deploy" with "0" argument(s): "ErrorCode<ERRCAdmin010>:SubStatus<ES0001>:Specified host is not present incluster." At C:\sp2013xxxxxxx\SP2013xxxxxx\AutoSPInstaller\AutoSPInstallerFunctions.ps1:3101 char:13 +             $distributedCachingSvc.ProcessIdentity.Deploy() +             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~    + CategoryInfo         : NotSpecified: (:) [], MethodInvocationException    + FullyQualifiedErrorId : CmdletInvocationException   WARNING: - An error occurred updating the service account for service AppFabricCachingService. -------------------------------------------------------------- -------------------------------------------------------------- - Configuring PDF file search, display and handling... - Adding PDF MIME type "application/pdf" web apps... - http://USNN01DEV:80: Adding "application/pdf"...Done. Also I saw the code it has the comments like this # This is still buggy ConfigureDistributedCacheService $xmlinput     
Jan 25, 2013 at 10:41 AM

actually I have seen this one myself as well. This was somehow an issue with the hostname itself. Are you using locahost in your config file or you entering the servername?

Jan 28, 2013 at 10:57 AM
Edited Jan 29, 2013 at 3:39 PM

I have tried this in (SP2013, Win 2012, SQL 2012) single-server farm and also in farms with 3+ servers and my observations are:

- Search Topology is not working with multiple servers. (i also had some issues trying to create a new topology after the application was created, but that may be unrelated to the main issue).

- Distributed cache is not working properly (does work well when installing with configuration wizard).



I have also discovered that the script does not give access to the Appool-account of the :80-webbapplication to the Content DB of MySites. This gives lots of issues with the social functionality if used in the :80-webbapplication.

I think these bugs have already been reported and i'm aware that the current release is in beta-mode for SP2013 but it sure would be nice to have an update soon :)

Jan 28, 2013 at 3:30 PM

Thought to continue this discussion instead of creating a new one. 

I have used the script to install SP2013 on 3 separate farm with window server 2012. I have encounter the following error on all farm. This tells me that there is something wrong with my configuration file. I would appreciate if you could guide me to the right direction. 

Log Name:      Microsoft-Windows-Kernel-EventTracing/AdminSource:        

Microsoft-Windows-Kernel-EventTracingDate:          2013-01-28 6:12:03 AM

Event ID:      2

SessionUser:          NE\farm

Description:Session "SharePointDiagnostics" failed to start with the following error: 0xC0000035Event

Xml:<Event xmlns="">  <System>    <Provider Name="Microsoft-Windows-Kernel-EventTracing" Guid="{B675EC37-BDB6-4648-BC92-F3FDC74D3CA2}" />    <EventID>2</EventID>    <Version>0</Version>    <Level>2</Level>    <Task>2</Task>    <Opcode>12</Opcode>    <Keywords>0x8000000000000010</Keywords>    <TimeCreated SystemTime="2013-01-28T11:12:03.239499100Z" />    <EventRecordID>16</EventRecordID>    <Correlation />    <Execution ProcessID="6448" ThreadID="9084" />    <Channel>Microsoft-Windows-Kernel-EventTracing/Admin</Channel>    <Computer>NetD13.ND.local</Computer>    <Security UserID="S-1-5-21-4002544113-1864723466-3015600954-13825" />  </System>  <EventData>    <Data Name="SessionName">SharePointDiagnostics</Data>    <Data Name="FileName">    </Data>    <Data Name="ErrorCode">3221225525</Data>    <Data Name="LoggingMode">256</Data>  </EventData></Event>