EnterpriseSearchService location should be pointing to the 15.0 folder for SharePoint 2013

Jan 9, 2013 at 3:24 AM
Edited Jan 9, 2013 at 3:25 AM

In the input file, the Index Location should be pointing at the 15 folder for SharePoint 2013 Installations<

 <EnterpriseSearchService Provision="true"
                                 InternetIdentity="Mozilla/4.0 (compatible; MSIE 4.01; Windows NT; MS Search 6.0 Robot)"
                                 IndexLocation="C:\Program Files\Microsoft Office Servers\14.0\Data\Office Server\Applications"
Jan 9, 2013 at 6:52 AM

check this issue in the issue tracker which deals with the search share:

The main comment from Brian: "Thanks , that's correct - like many other parameters in the XML, the SearchIndex path should be reviewed and set appropriately for the version of SharePoint. Of course I could have simply had the script set it accordingly based on the detected version of SharePoint being installed, but many folks like to set this path to an arbitrary value (e.g. D:\SearchIndex) so I wanted to retain support for that too."


Feb 8, 2013 at 2:30 PM
I've noticed this to. Thanks for the post!
Jul 31, 2013 at 1:31 PM

this is an important ISSUE that needs immediate fix. After prawnz's comment, I think the IndexLocation is left blank.

I downloaded the latest version on 29 July 2013.
The index location was empty. and although this is not the first time I use AutoSPInstaller, I did not notice this and I installed leaving IndexLocation empty.

this caused, the search index location to be set to a wrong folder, which is the temporary installation folder where AUTOSPINSTALLER exists.

such as

C:\SP\AutoSPInstaller\Office Server

I accidentally deleted some of the files in this C:\SP\AutoSPInstaller\Office Server folder, and then the search Windows service stopped. leaving me issues in the event viewer.

Please STOP the execution of the script if the INDEX LOCATION is empty.

the current settings.
<!-- Note the change below for CustomIndexLocation; you only need to specify a path here if you would like to specify a non-default path for the search index (e.g. D:\SearchIndex) otherwise the default value will be applied: "$env:ProgramFiles\Microsoft Office Servers\$env:spVer.0\Data\Office Server\Applications" (where $env:spVer is either 14 or 15) --> -<EnterpriseSearchService Password="" Provision="true" ShareName="SearchIndex" Account="DOMAIN\SP_SearchService" PerformanceLevel="PartlyReduced" CustomIndexLocation="" InternetIdentity="Mo.....

you also need to correct the comment.