This project has moved and is read-only. For the latest updates, please go here.

adding new server to farm error

Aug 27, 2012 at 6:48 PM


When I run the autospinstaller on a new server to add to the farm, when it try to join the farm I get the following error:

Microsoft.SharePoint.SPException: This SharePoint farm currently has pending upgrades.

After that I tried to run the configuration manually and it found the config database and took the paraphrase. I then exit out of the wizard before it creates the join to the farm and I re-run the script and it runs fine.

Is there a reason why when the script runs the first time it is not taking the paraphrase correctly and after running through the wizard half way the script runs without issues?

I have run this on multiple new farm servers and it acts the same way.



Aug 29, 2012 at 7:04 AM

Does your farm have upgrades pending? You can check through Central Administration > Upgrade and Migration > Check Upgrade Status and also Check product and patch installation status.

Do you have/use the Office Web Application (OWA) apps?

You can also run the following PSConfig command to upgrade your farm: psconfig –cmd upgrade –inplace b2b –wait –force

Here is some more information regarding Sharepoint 2010 (with Office web products): 


Aug 29, 2012 at 1:08 PM
Edited Aug 29, 2012 at 2:02 PM


I have check both the upgrade and migration and the product and patch installation status. There are no upgrades pending and all products are installed. I don't think what the error is stating is actually what the problem is. I think that the paraphrase somehow is not getting presented correctly and erroring out when trying to add a new server to an existing farm. At first attempt I did tihnk the database needed to be upgrade and ran the psconfig command but the other servers still failed at the same spot. Really think it has something to do with the paraphrase.

Office Web Apps are installed, but also checking the installation status all is showing installed.



Aug 29, 2012 at 11:09 PM

Does your Paraphase have any of the following characters?

 1. If you use the characters ' " < > & in your configuration (e.g. in passwords) you should encode them as follows:

        ' &apos;
        " &quot;
        < &lt;
        > &gt;
        & &amp;
      For example <Password>Fd"je&f</Password> should be written <Password>Fd&quot;je&amp;f</Password>

If so, you will need to update it with the above.

You can also check your XML here: - this will let you know if something is incorrect.

Aug 29, 2012 at 11:27 PM

No the password is just letters and numbers, and I am using a xml editor, but I did put the xml file in the validator and get no error. Is there anyway to get this to be a more verbose error. It seems that this error happens if anything goes wrong but is not really telling you what the issue maybe. Again if I run the wizard put the sql server in, retrieve the db and click next, enter the paraphrase, click next and then cancel the script runs fine.



Nov 8, 2012 at 4:18 AM

Did you eventually get this resolved?


Nov 8, 2012 at 1:36 PM

Yes, I had to put a check before you added a server to check to see if the database was in an upgrade status. Once that was set it works find now.


Mar 4, 2013 at 7:16 PM
Would you be willing to share the code for your check? I'm running in to this same issue.

dclah918 wrote:
Yes, I had to put a check before you added a server to check to see if the database was in an upgrade status. Once that was set it works find now. Dan