Waiting for Help Collection Installation timer job to complete: 0% Hung

Jun 7, 2012 at 12:02 PM

Hi all,

I saw that v3 came out and I wanted to test out the Remote install functionality. Unfortunately I can't seem to get off the ground with this! I have migrated my Input.xml via BeyondCompare into the v3 format and it's all going as expected until it comes to Waiting for Help Collection Installation timer job to complete.

It has been stuck on 0% for around an hour now and I have tried kicking off SPAutoInstaller again and it hangs at the same point. I have tried restarting the Timer Service but that doesn't help. It creates new jobs that again stuck at 0%.

Any ideas on where to go with one?

Jun 13, 2012 at 7:46 PM

Bump.. same problem here.

Jun 16, 2012 at 10:43 PM

Most likely there's something unique about your environment but it could be your XML file as well. Can you post it?

Jun 19, 2012 at 12:11 PM

Thanks for getting back to me Wahid. Happy to share it as this is a show stopper currently with the remote install.

I had a bit of trouble trying to add it to this thread using the code snippet tool. I'm not sure if it was too long.. Anyways I have uploaded it to pastebin and it can be found here



Jun 19, 2012 at 8:40 PM

I had the same issue.  I ended up reverting back to an earlier build to get around the problem.

Jun 30, 2012 at 3:55 AM

FYI - this functionality (waiting for the Help Collection Timer Job) was implemented as a workaround/fix for another issue that occurs when installing Language Packs. I'm currently testing a fix to the latter issue that, if successful, could mean we can get rid of this one altogether... stay tuned.

In the meantime, you could try just commenting out the two instances of the line:


In AutoSPInstallerFunctions.ps1.