terrible naming conventions

Apr 11, 2012 at 1:31 AM

Hi, first of all AutoSPInstaller is awesome and amazing work. However could something please be done about the stupid backwards naming conventions of items in the configuration files.

For example any normal person would be forgiven for thinking that

<IEEnhancedSecurity>true

means IEEnhanced Security will be enabled. Or that

<LoopbackCheck>true

means that loopbackcheck would be on or enabled or even that it's status is "true". However as you all know in fact the opposite is true.

Please change these in the new version to something reasonable like:

<IEEnhancedSecurityDisable>true - this would make it so much more understandable and actually conform to logic.

Coordinator
Apr 11, 2012 at 2:54 AM

One level up in the XML, you'll see that the entire parent element is called <Disable> meaning all sub-elements are things that can be disabled. So, true and false make sense when you read it with the parent element followed by the child, e.g. <Disable><LoopbackCheck>true</LoopbackCheck>. Maybe not perfect but at this point changing the names might be more trouble than it's worth.

Brian

Apr 13, 2012 at 12:05 AM

Ok that does make a lot more sense. In that case, it would be perfect then if the comments for each field could clearly specify what will happen if they are set to each value.