Domain Accounts not seen

Feb 29, 2012 at 6:23 PM

Getting this error on every run.   I've verifyed connectivity to the DC, and that the user accounts exest in the AD

 

- Applying object cache accounts to "http://TCOSHAREPOINT:80"...
Exception calling "Add" with "2" argument(s): "The specified user or domain group was not found."
At Z:\Data\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1642 char:74
+ [Microsoft.SharePoint.Administration.SPPolicy]$policy = $policies.Add <<<< ($userName, $displayName)
+ CategoryInfo : NotSpecified: (:) [], MethodInvocationException
+ FullyQualifiedErrorId : DotNetMethodException
 WARNING: - An error occurred applying object cache to "http://TCOSHAREPOINT:80"
Press any key to exit...

 

Here is the related setting in the xml file and it is the same account I am using to create the Web Application (I have tried alternat accounts and I get exactly the same error on the MySite creation

                <SiteCollection siteUrl="http://localhost"
                                owner="ACME\SPS_APP_POOL"
                                name="Portal Home"
                                description="Portal Home Site"
                                SearchUrl="http://localhost/search"
                                CustomTemplate="false"
                                Template="SPSPORTAL#0"
                                LCID="1033"
                                Locale="en-us"
                                Time24="false">
                </SiteCollection>


Coordinator
Mar 1, 2012 at 1:15 AM

What object cache accounts (super user and super reader) have you specified in the XML, and in what format (DOMAIN\user or user@domain.com)?

Brian

Mar 2, 2012 at 2:51 PM

        <ObjectCacheAccounts>
            <SuperUser>ACME\SPS_CACHEADM</SuperUser>
            <SuperReader>ACME\SPS_CACHERD</SuperReader>
        </ObjectCacheAccounts>

Coordinator
Mar 2, 2012 at 6:36 PM

What happens if you try to add these users to, for example, a local group (e.g. Power Users) on the machine? Just trying to determine why the user names aren't resolving.

Brian

Mar 6, 2012 at 10:47 PM

I fixed this - As you suspected there was a type in the Reader account name - sorry for confusion

Mar 9, 2012 at 1:54 AM

Salve!  I downloaded the AutoSPInstaller on March 6.  I am having the same error.  I created the accounts to match what I put in the config.xm, very similar to what webguynj did.  I went and looked at the Cache user, and saw that the "Windows 2000" login name was missing a few letters from the end.  I think if the names are too long it tries to trim them.  At any rate, I fixed that and the script continued.