This project has moved and is read-only. For the latest updates, please go here.

New User Stuck "Applying Updates"

Feb 28, 2012 at 5:22 PM

Which logs should I review because SP installation is stuck about 50% through and says "applying Updates" but won't move any furhter and isn't failing

Feb 29, 2012 at 2:39 AM

Hi there,

Have a look in your %TEMP% for a log file named something like "SharePoint Server Setup".

I've also seen cases lately where the installation never seems to finish, but the log file doesn't really show any errors. Not sure why, I just blamed wonky VMs at the time, re-ran on new machines and it went through fine.


Feb 29, 2012 at 6:15 AM


On my last installation it got stuck on "applying updates" for around 1,5 to 2 hours on two VMWare machines. Both disconnected from internet, not sure if this could be an issue (?).

In the event log I saw evidence that "something" got updated, so I knew it would eventually finnish. 

How long did you wait?

Cato Antonsen

Feb 29, 2012 at 7:14 PM

Definitely looks like there is a timeout going to the internet.   Why is internet connectivity required to install SharePoint or Web Aplications?

Mar 1, 2012 at 12:39 AM

When you install a MS product like SharePoint, the OS will check the validity of the certificates that digitally sign the code by checking the CRL (certificate revocation list). If you don't have Internet connectivity, the install will complete but will take somewhat longer as each CRL request times out (20-30 seconds each I think).

There is a setting in AutoSPInstallerInput.xml as follows:

            <!-- Switch off checking whether the code-signing certificates used to sign the SharePoint code have been revoked. This slows down the
                 start up time for SharePoint, particularly if the server cannot connect to the Internet to perform the revocation check. -->

This might help in a case like yours where the server doesn't have Internet connectivity.



Mar 1, 2012 at 6:21 AM

So "true" mean it will turn the check off?

If so; it makes more sense to call it DisableCertificateRevocationListCheck... ;-)