$ProfileServiceApp.SetSynchronizationMachine throwing error

Aug 17, 2011 at 1:33 PM

Dear all,

either my farmpassword, with encoded illegal XML characters is giving a problem or maybe the suggestion here is worth lookint at : http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/d65d75aa-f9dc-4957-820f-e8e59ff98181/

I would rather though not change the script on the UPS part. Anybody have a solution to this?

- Updating User Profile Synchronization Service to run as Domain\spservices_test... - Waiting for User Profile Synchronization Service...Exception calling "SetSynchronizationMachine" with "4" argument(s): "Operation is not valid due to the current state of the object."At ...\SP2010\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1944 char:50+                     $ProfileServiceApp.SetSynchronizationMachine <<<< ($env:COMPUTERNAME, $ProfileSyncService.Id, $FarmAcct, (ConvertTo-PlainText $FarmAcctPWD))    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException    + FullyQualifiedErrorId : DotNetMethodException


Thank you in advance.


Nico de Jong

Aug 18, 2011 at 12:00 PM

Solved : Was using a named instance. Have a look here under named instance (second part) : http://www.harbar.net/articles/sp2010ups2.aspx

The Local DTC has to be set to allow inbound connections. I was able to run the UPS by hand, not yet scripted. But expect this was the problem.

Aug 18, 2011 at 12:00 PM
Edited Aug 18, 2011 at 12:00 PM


Dec 17, 2011 at 3:38 AM

Curious, have you tried using a SQL alias instead of addressing the named instance directly? I've never had to mess with the Local DTC settings myself.


Dec 19, 2011 at 8:49 AM


I am using a SQL alias like SQLDEVALIAS mapped to SERVERNAME\INSTANCENAME and port determined.

I use a non standard port.