Error Setting Excel Services Trusted File Location & Portal Home Access denied

Aug 5, 2011 at 2:35 PM
Edited Aug 6, 2011 at 10:17 AM

Hi Mates,

 i get this error when i let run the script, can anyone help me ? i get a message that Set-SPExcelFileLocation : Objekt http:// cannot be found

 ( This is my last error in the script ( For German Language )

Here beginns the Error Output from Power Shell Script 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

- Provisioning Excel Calculation Services...

- Checking Dienste für Excel-Berechnungen instance...

- Dienste für Excel-Berechnungen instance already started.

- Excel Calculation Services already provisioned.

- Setting Excel Services Trusted File Location...

Set-SPExcelFileLocation : Objekt http:// kann nicht gefunden werden.

Bei D:\SP2010\AutoSPInstaller\AutoSPInstallerFunctions.ps1:3371 Zeichen:27

+ Set-SPExcelFileLocation <<<< -Identity "http://" -LocationType S

harePoint -IncludeChildren -Address $PortalURL`:$PortalPort -ExcelServiceApplic

ation $($ServiceConfig.Name) -ExternalDataAllowed 2 -WorkbookSizeMax 10

+ CategoryInfo : InvalidData: (Microsoft.Offic...celFileLocation:

SetSPExcelFileLocation) [Set-SPExcelFileLocation], ExcelServerObjectNotFou

ndException

+ FullyQualifiedErrorId : Microsoft.Office.Excel.Server.Cmdlet.SetSPExcelF

ileLocation

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Here ends the Error Output from Power Shell Script  

Here is the start code from my AutoSpinstallerFunktion.ps1

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

{
  WriteLine
  $PortalWebApp = $xmlinput.Configuration.WebApplications.WebApplication | Where {$_.Type -eq "Portal"}
  $PortalURL = $PortalWebApp.URL
  $PortalPort = $PortalWebApp.Port
  $ServiceInstanceType = "Microsoft.Office.Excel.Server.MossHost.ExcelServerWebServiceInstance"
  CreateBasicServiceApplication -ServiceConfig $ServiceConfig `
           -ServiceInstanceType $ServiceInstanceType `
           -ServiceName $ServiceConfig.Name `
           -ServiceProxyName $ServiceConfig.ProxyName `
           -ServiceGetCmdlet "Get-SPExcelServiceApplication" `
           -ServiceProxyGetCmdlet "Get-SPServiceApplicationProxy" `
           -ServiceNewCmdlet "New-SPExcelServiceApplication -Default" `
           -ServiceProxyNewCmdlet "New-SPExcelServiceApplicationProxy" # Fake cmdlet (and not needed for Excel Services), but the CreateBasicServiceApplication function expects something
          
  If (Get-SPExcelServiceApplication)
  {
   Write-Host -ForegroundColor White " - Setting Excel Services Trusted File Location..."
   Set-SPExcelFileLocation -Identity "http://" -LocationType SharePoint -IncludeChildren -Address $PortalURL`:$PortalPort -ExcelServiceApplication $($ServiceConfig.Name) -ExternalDataAllowed 2 -WorkbookSizeMax 10
  }
  WriteLine
 }

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- 

Here is the end of code from my AutoSpinstallerFunktion.ps1

One another Problem what i have is the second site what opens when script is finished i get a Access Denied

This is th Portal Home website on Port 80

With the MySiteHost and Sharepoint Central Administration site i dont have problems.

here its the URL:

 http://servername/_layouts/AccessDenied.aspx?Source=http%3A%2F%2Fsrv%2Dfile%2D01%2FSeiten%2FDefault%2Easpx&Type=list&name=%7B8DCAC3BB%2D1A41%2D46C7%2DB47D%2D800B3CA2BBC3%7D

Fehler: Zugriff verweigert

Aktueller Benutzer

Sie sind zurzeit angemeldet als: Domain\username

 

Mit anderem Benutzernamen anmelden

 

 

 

 

Oct 24, 2011 at 7:06 PM
Edited Oct 24, 2011 at 7:16 PM

Me too!!!

I get set-spexcelfilelocation error that you get.....
There must be someone out there also getting this - the strange part is that it uses -Identity http:// - what identity is that???? - seen it several places on the internet, and no mention about it being wrong... maybe it is something else?

Brian?

Cheers :-)

Regard
Jesper

Coordinator
Dec 17, 2011 at 4:57 AM

Is this still an issue guys? Sorry haven't looked at it lately, have never been able to reproduce myself though.

Brian

Apr 10, 2012 at 5:08 PM

HI,

just came across this issue myself today when I was dealing with office webapps. Seems like the line within CreateExcelOWAServiceApp

Set-SPExcelFileLocation -Identity "http://" -LocationType SharePoint -IncludeChildren -Address $PortalURL`:$PortalPort -ExcelServiceApplication $($ServiceConfig.Name) -ExternalDataAllowed 2 -WorkbookSizeMax 10

does not properly create the trusted file location. Instead I tried this one:

New-SPExcelFileLocation -Address "http://" -LocationType SharePoint -IncludeChildren -ExcelServiceApplication $($ServiceConfig.Name) -ExternalDataAllowed 2 -WorkbookSizeMax 10 | Out-Null

seems to work correctly (currently working with v3!) I did not try with Excel Services. In addition perhaps needs some adjustment to also capture SSL based sites. Will test some more.

Stefan