Language pack installation issue

Jun 21, 2011 at 1:07 PM
Edited Jun 21, 2011 at 1:08 PM

i am try to install language pack in sharepoint 2010, i am getting error like "Language pack for sharepoint, Project server and office web apps 2010 - English encounter an error during setup". plz suggest the solution

Thanks in advance

Coordinator
Jun 23, 2011 at 5:20 AM

Can you post/paste the exact error, along with some more info? Like, does this happen during the script execution, or are you seeing this in Central Admin once install has completed?

Thx
Brian

Jun 28, 2011 at 5:53 PM

 - Configuring language packs...
SharePoint Products Configuration Wizard version 14.0.4762.1000. Copyright (C) M
icrosoft Corporation 2010. All rights reserved.

Performing configuration task 1 of 4
Initializing SharePoint Products upgrade...

Waiting to get a lock to upgrade the farm.

Successfully initialized SharePoint Products upgrade.

Performing configuration task 2 of 4
Initiating the upgrade sequence...

Successfully initiated the upgrade sequence.

Performing configuration task 3 of 4
Upgrading SharePoint Products...

Failed to upgrade SharePoint Products.

An exception of type Microsoft.SharePoint.Administration.SPUpdatedConcurrencyExc
eption was thrown.  Additional exception information: An update conflict has occ
urred, and you must re-try this action. The object SPUpgradeSession Name=Upgrade
-20110628-114417-55 was updated by MEMCSTL\STP-DEV-SPAdmin, in the PSCONFIG (393
6) process, on machine STPSPWC02.  View the tracing log for more information abo
ut the conflict.

Total number of configuration settings run: 3
Total number of successful configuration settings: 2
Total number of unsuccessful configuration settings: 1
Successfully stopped the configuration of SharePoint Products.
Configuration of SharePoint Products failed.  Configuration must be performed be
fore you use SharePoint Products.  For further details, see the diagnostic log l
ocated at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\1
4\LOGS\PSCDiagnostics_6_28_2011_11_44_13_352_48205127.log and the application ev
ent log.
WARNING: 06/28/2011 11:44:24  1  ERR      Post setup configuration was not run
successfully when using the command line task driver module
 - An error occurred configuring language packs, trying again using GUI...
--------------------------------------------------------------

 

This keeps happening to me. Problem is, if I let the GUI run the language pack upgrade, i started to get other errors and funky behavior when the script continues.

Coordinator
Aug 7, 2011 at 4:04 PM

At least in my experience, this issue seems to have subsided in later releases of both AutoSPInstaller and SharePoint (SP1 and June 2011 CU). Hope it's working better for you as well...?

Brian

Oct 5, 2011 at 8:14 PM

- Configuring language packs...
SharePoint Products Configuration Wizard version 14.0.6009.1000. Copyright (C) M
icrosoft Corporation 2010. All rights reserved.

Performing configuration task 1 of 4
Initializing SharePoint Products upgrade...

Waiting to get a lock to upgrade the farm.

Successfully initialized SharePoint Products upgrade.

Performing configuration task 2 of 4
Initiating the upgrade sequence...

Successfully initiated the upgrade sequence.

Performing configuration task 3 of 4
Upgrading SharePoint Products...

Failed to upgrade SharePoint Products.

An exception of type Microsoft.SharePoint.Administration.SPUpdatedConcurrencyExc
eption was thrown.  Additional exception information: An update conflict has occ
urred, and you must re-try this action. The object SPUpgradeSession Name=Upgrade
-20110930-093451-541 was updated by DATYS\ssd.install, in the PSCONFIG (3804) pr
ocess, on machine E22-SIE-SRV-12.  View the tracing log for more information abo
ut the conflict.

Total number of configuration settings run: 3
Total number of successful configuration settings: 2
Total number of unsuccessful configuration settings: 1
Successfully stopped the configuration of SharePoint Products.
Configuration of SharePoint Products failed.  Configuration must be performed be
fore you use SharePoint Products.  For further details, see the diagnostic log l
ocated at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\1
4\LOGS\PSCDiagnostics_9_30_2011_9_34_44_631_2079755946.log and the application e
vent log.
WARNING: 09/30/2011 09:35:04  1  ERR      Post setup configuration was not run
successfully when using the command line task driver module
 - An error occurred configuring language packs, trying again using GUI...
 
 ------------------------------------------------------------------------------------
 Exception: Microsoft.SharePoint.Administration.SPUpdatedConcurrencyException: An update conflict has occurred, and you must re-try this action. The object SPUpgradeSession Name=Upgrade-20110930-093451-541 was updated by DATYS\ssd.install, in the PSCONFIG (3804) process, on machine E22-SIE-SRV-12.  View the tracing log for more information about the conflict.
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.StoreObject(SPPersistedObject obj, Boolean storeClassIfNecessary, Boolean ensure)
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.Microsoft.SharePoint.Administration.ISPPersistedStoreProvider.PutObject(SPPersistedObject persistedObject, Boolean ensure)
   at Microsoft.SharePoint.Administration.SPPersistedObject.BaseUpdate()
   at Microsoft.SharePoint.Upgrade.SPUpgradeSession.Update()
   at Microsoft.SharePoint.Upgrade.SPUpgradeSession.ContinueOnLocalThread(Guid id, Boolean consoleOutput)
   at Microsoft.SharePoint.Upgrade.SPManager.ContinueSessionOnLocalThread(Guid id, Boolean consoleOutput)
   at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()
  
  --------------------------------

I Have ERROR... Who to resolved????  please .. i need HELP

Oct 5, 2011 at 8:14 PM
Edited Oct 5, 2011 at 8:20 PM

- Configuring language packs...
I Have ERROR... Who to resolved????  please .. i need HELP, I have (SP1 and June 2011 CU fixxed and try with Agust 2011 CU and failed too) HELP PLEASE!!

 

 

Oct 20, 2011 at 2:57 PM
Edited Oct 20, 2011 at 2:58 PM

.

Oct 20, 2011 at 2:58 PM

The only easy workaround I found so far is the following:

1) don´t use any languagepacks at the initial installation ! (leave the directory empty or rename/prefix the files)

2) after AutoSpinstaller successfully installed, remove the sites "portal" and "mysite" (incl. ContentDB)

3) install the Languagepack manually and continue with the "SharePoint Configuration Wizard"

4) now modify the XML (LanguageID,TimeSettings,...)

5) Run the AutoSpInstaller-Script again.

Done, have fun

Oct 20, 2011 at 3:24 PM

Quick note here :

I followed the instruction in the text files in the language pack folder and it is working.

SPS Folder : sps rtm slipstreamed with sp1 extracted into the updates folder + CU june 2011 extracted into the updates folder

Language pack folder : subfolder FR-FR (for french) with subfolder updates

extract sharepoint server only (if using server) to FR-FR (your language) folder and extract the language pack SP1 in the updates folder.

extract the CU exe file into a temp folder. (you have alerady extracted it to the SPS updates folder but repeat here just to avoid confusion.

copy the FR-FR files from the CU extracted folder in the updates folder of your language pack FR-FR\updates.

install and check product version.

 

 

Oct 20, 2011 at 3:26 PM

another quick note: once your install starts throwing errors you better restart from a clean machine.

Jan 2, 2012 at 10:39 PM
Edited Jan 2, 2012 at 10:40 PM

I encounter the same problem. My folder structure:

- Sharepoint SP2010 bin

- Updates: SP1 extracted

- LanguagePacks

- DE-DE: Language Pack extracted

- Updates: Language Pack SP1 extracted

Is there any fix for this issue?

Coordinator
Jan 25, 2012 at 3:38 AM

I still run into this frequently myself - I work around it by running the PSConfigUI.exe which for some reason doesn't have the same problem as PSCONFIG.exe.

Brian

Feb 29, 2012 at 2:39 PM

I'm still running into this with the December CU. I tried making it attempt to configure it a few tries before relying on the GUI, but it never worked out. I hope the next service pack fixes it all.