Removing Mysites creation

Apr 15, 2011 at 4:09 PM

Our organiztion is not going to be useing the mysites feature in sharepoint.  I removed the section used for creating this but it still gives me an error when doing the install.  Is there a way to fix this or should i just leave the mysites section and delete after the fact.

Apr 15, 2011 at 4:12 PM
Edited Apr 15, 2011 at 4:13 PM

Hi Stanleyj42,

I bet your error is coming up with it tried to add the Mysite URL to the search service.  If you look in the AutoSPInstallerFunctions.ps1 file for the following line:

$CrawlStartAddresses = $PortalURL+":"+$PortalPort+","+$MySiteURL+":"+$MySitePort+","+$PeopleSearchProtocol+$MySiteHostHeader+":"+$MySitePort

Change it to:

$CrawlStartAddresses = $PortalURL+":"+$PortalPort

 

Rick

Apr 15, 2011 at 4:13 PM

Also,

Are you setting up user profile services?

Apr 15, 2011 at 5:02 PM

I have removed the line you specified above and will give it another shot.  Yes i am setting users profile services.  Something else i have noticed is that my hotfix does not install either.  I have copied to the updates folder like the documention says. 

 

rtonerii thank you for your help on this.  If i have to install everything defualt and edit after i will.  Because getting the databases to look nice and neat from the get go is worth it in itself!!

Apr 15, 2011 at 5:08 PM

I think it might be easier to just let it create the mysite web app and then delete it all.  I was looking thru the code and $mysite is everywhere for the profile service setup. 

 

Apr 15, 2011 at 5:11 PM

Hi Stanley,

Since you will be installing the User Profile Service.  It will just be easier to let it create the Mysite and then just delete it.

There is a setting in the Mysite that the User Profile Services calls.

Rick

Coordinator
Apr 15, 2011 at 11:14 PM

I'm pretty sure you need a My Sites web app in order to provision UPS. However I do need to fix the part of the Search Service function that adds the My Site URL to the content source (if there's no my site).

You guys are correct in that the current easiest thing is to let the script provision everything re: My Sites then either delete what you don't need, or just remove all permissions to those personalization features so nobody sees the My Sites links etc.

Brian