Creating User Profile Service Application This command cannot be executed due to the error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Mar 14, 2011 at 2:53 PM

- Creating User Profile Service Application...

Start-Process : This command cannot be executed due to the error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

At C:\AutoSPInstaller\SP2010\AutoSPInstaller\AutoSPInstallerFunctions.ps1:1522

char:16

+ Start-Process <<<< $PSHOME\powershell.exe -Credential $FarmCredentia

l -ArgumentList "-Command Start-Process $PSHOME\powershell.exe -ArgumentList `"

'$ScriptFile'`" -Verb Runas" -Wait

+ CategoryInfo : InvalidOperation: (:) [Start-Process], InvalidOp

erationException

+ FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.C

ommands.StartProcessCommand

 

Press any key to exit...

- Waiting for User Profile Service Application............................................................................................................................

WARNING: - Timed out waiting for service creation (maybe a UAC prompt?)

 

- Press any key to try again

Start-Process : This command cannot be executed due to the error: The service c

annot be started, either because it is disabled or because it has no enabled de

vices associated with it.

 

Any idea how to address this error.

Coordinator
Mar 15, 2011 at 11:53 AM

Hmm can you check on the status of the Secondary Logon service? I suspect it's trying to do a RunAs but can't, possibly because this service is disabled.

Brian