two separate <services> sessions

Feb 7, 2011 at 9:03 PM

Could someone explain to me why there are two separate <Services> sessions in AutoSPInstallationInput.xml file?

One <services> session includes Metadata Service, User Profile Services, ... The other includes the rest of the services?

Is that possible for me to set the Provision="False" for all services when build web front servers and set Provision="True" for all services when build Application server?

Thanks in advance,

Peter

 
Coordinator
Feb 7, 2011 at 9:33 PM
Quite correct, one of them should be called <ServiceApplications> instead, will add as a task. I will also look into your proposed global Boolean flag for services and service apps respectively. Brian
Coordinator
Feb 7, 2011 at 9:35 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Feb 7, 2011 at 11:19 PM

Hi Brian,

Do you think it is good idea to install all items in both <Services> and <ApplicationServices> sections into an Application Server (APP Server) instead of install them into WFE servers? 

Thanks,

Peter 

 

Coordinator
Feb 7, 2011 at 11:41 PM
Depends - Microsoft released a good Visio diagram recently that provides guidance on which services run on which server roles, sorry I don't have the URL right now!
Feb 8, 2011 at 2:10 AM

Brian,

Really appreciate your help!

I have googled Microsoft Visio diagram related with SharePoint service applications deployment, but did not find the one you mentioned. If you still have that url, could you share with us?

Thanks again for your help!

Peter 

 

 

Feb 8, 2011 at 10:52 AM

Here you go:

http://technet.microsoft.com/en-us/library/cc263199.aspx

+1 from me for making a  Boolean flag for services and service apps respectively - that would be nice...

Coordinator
Feb 11, 2011 at 1:44 AM

@timiun, thanks again for coming through...!

Brian