Directory Name is Invalid - User Profile Service Application

Dec 10, 2010 at 2:13 AM

Hi, thank you SO much for putting this script together, it has saved me weeks so far.  I grabbed the recent version today to get some of your latest updates and I'm seeing this error.  I thought it might be a permissions issue with the temp folder (for some reason, so I changed the location the temp script saves to C:\ and it gets created there.  I'm not sure what the deal is.  I pasted a second error as well but it could just be an artifact of the first one. 

Any ideas?

Thanks,

-Ryan

- Creating User Profile Service Application...

Receive-Job : [localhost] There is an error launching the background process. E

rror reported: The directory name is invalid.

At Z:\MERLINInstallScripts\SP2010\ScriptedInstall\AutoSPInstaller.ps1:1112 char

:15

+ Receive-Job <<<< -Name CreateProfileServiceAppJob -Verbose

+ CategoryInfo : OpenError: (:) [Receive-Job], PSRemotingTranspor

tException

+ FullyQualifiedErrorId : PSSessionStateBroken

Remove-Item : Cannot find path 'C:\Users\MERLIN~1\AppData\Local\Temp\2\AutoSPIn

staller-ScriptBlock.ps1' because it does not exist.

At Z:\MERLINInstallScripts\SP2010\ScriptedInstall\AutoSPInstaller.ps1:1114 char

:15

+ Remove-Item <<<< -Path "$env:TEMP\AutoSPInstaller-ScriptBlock.ps

1"

+ CategoryInfo : ObjectNotFound: (C:\Users\MERLIN...ScriptBlock.p

s1:String) [Remove-Item], ItemNotFoundException

+ FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.Remov

eItemCommand

 

- Creating User Profile Service Application Proxy...

New-SPProfileServiceApplicationProxy : Cannot validate argument on parameter 'S

erviceApplication'. The argument is null. Supply a non-null argument and try th

e command again.

At Z:\MERLINInstallScripts\SP2010\ScriptedInstall\AutoSPInstaller.ps1:1121 char

:134

+ $ProfileServiceAppProxy = New-SPProfileServiceApplicationProxy -

Name "$UserProfileServiceName Proxy" -ServiceApplication <<<< $ProfileServiceA

pp -DefaultProxyGroup

+ CategoryInfo : InvalidData: (:) [New-SPProfileServiceApplicatio

nProxy], ParameterBindingValidationException

+ FullyQualifiedErrorId : ParameterArgumentValidationError,Microsoft.Offic

e.Server.UserProfiles.PowerShell.SPCmdletNewProfileServiceApplicationProxy

Dec 21, 2010 at 1:52 PM

Hi,

any updates/information regarding this one?

I'm receiving the same error, except I'm using the default ps1 file, so the error is located on rule 1088, and same error message: directory is invalid.

I'm launching the bat file from another Powershell script file like so:

C:\Scripts\configureVM.ps1 --> This is my main powershell script, this will call the launch.bat file like:

function test
{
c:\scripts\resources\spinstall\autospinstaller\launch.bat
}

Any help???