Install Failure in clean environment

Dec 7, 2010 at 2:12 PM

I tried installing on a virtual machine running Windows Server 2008 R2 64-bit + SQL Server 2008 R2 Enterprise 64-bit, both fully patched through December 6, 2010, but received an error (see below) while installing as user Administrator.  Please note that I right-clicked on C:\SP2010\AutoSPInstaller\Launch.bat and chose Run As Administrator.

I check SQL Server Management Studio and there are no new databases.

Although I don't see it in the log file, I believe the screen output indicated a problem installing/configuring some PowerShell cmdllets, but I dismissed that screen before realizing that particular error wasn't recorded anywhere.

Any advice on how to proceed would be appreciated.

Partial log output (last portion):

- All Prerequisite Software installed successfully.
- Installing SharePoint binaries...
- Waiting for SharePoint Products and Technologies Wizard to launch...Done.
- Exiting Products and Technologies Wizard - using Powershell instead!
 - No language packs found in C:\SP2010\LanguagePacks, skipping.
 - Currently installed languages:
  - English (United States)
- Creating & configuring (or joining) farm:
 - Enabling SP PowerShell cmdlets...
 - Checking farm membership for EXAMPLEVM in "EXAMPLEVM_ConfigDB"...

 - Attempting to join farm on "EXAMPLEVM_ConfigDB"...
 - No existing farm found.
 - Creating config database "EXAMPLEVM_ConfigDB"...

New-SPConfigurationDatabase : SPService
At C:\SP2010\AutoSPInstaller\AutoSPInstaller.ps1:577 char:31
+             New-SPConfigurationDatabase <<<<  –DatabaseName "$ConfigDB" –Data
baseServer "$DBServer" –AdministrationContentDatabaseName "$CentralAdminContent
DB" –Passphrase $SecPhrase –FarmCredentials $Cred_Farm
    + CategoryInfo          : InvalidData: (Microsoft.Share...urationDatabase:
   SPCmdletNewSPConfigurationDatabase) [New-SPConfigurationDatabase], Win32Ex 
  ception
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPCon
   figurationDatabase
 
ScriptHalted
At C:\SP2010\AutoSPInstaller\AutoSPInstaller.ps1:578 char:23
+             If (-not $?) {throw <<<< }
    + CategoryInfo          : OperationStopped: (:) [], RuntimeException
    + FullyQualifiedErrorId : ScriptHalted
 
Press any key to exit...

Coordinator
Dec 7, 2010 at 3:14 PM

Does the user whose credentials you are running the script as have explicit permissions to create databases on the SQL instance? Remember that in SQL 2008, being a member of the local Administrators group doesn't automatically grant you sysadmin rights in SQL. Therefore I'd start by checking the SQL permissions of the user running the script.

I realize the script is supposed to check for this, but unfortunately it isn't that thorough.

Brian

Mar 25, 2011 at 11:59 AM

We received the same error message when we had the wrong domain name for the users in SetInputs.xml. At first, the script didn't complain about the domain being wrong but when the config database was to be created, the error appeared.

It's just unfortunate that the error message is a bit vague, but it seems to be related to the user and its rights.