Managed Account Error

Nov 30, 2010 at 9:14 PM

I've been working through the first farm setup with your tool, and I love the concept.  We're having an issue getting past an error however.  I ran the tool successfully once, but my database naming was not correct.  I ran the Products Configuration Wizard, remvoed the farm, deleted the databases, and re-ran.  How when I run it gives an error as shown below.  The managed account appears to be created fine, and exists in Central Admin (I can assign it to a new app pool when creating a web app), but it causes other elements in the script (such as the UserProfile service) to not be created properly or have the wrong account assigned.  I've tried deleting the SharePoint binaries as well and starting the whole process over again, as well as creating a new account and using that, all to no avail.  Any suggestions?

Thanks,
Peter Carson

- Registering managed account clarimer

- Registering managed account lfolts

- Registering managed account tpietz

- Starting Microsoft SharePoint Foundation Sandboxed Code Service...

- Waiting for Sandboxed Code service to start............Started!

- Managed Account clarimer not found

At C:\Users\pacarson\Documents\SP2010\AutoSPInstaller\AutoSPInstaller.ps1:705 c

har:49

+           If ($ManagedAccountGen -eq $NULL) { throw <<<<  "- Managed Account

$AppPoolAcct not found" }     

    + CategoryInfo          : OperationStopped: (- Managed Account clarimer no

   t found:String) [], RuntimeException

    + FullyQualifiedErrorId : - Managed Account clarimer not found

 

Coordinator
Nov 30, 2010 at 10:39 PM

Hi there, I'm surprised it got as far as it did because all accounts in the script need to be in the form DOMAIN\username, whereas it appears you've tried to add them using just username. Can you try prepending the domain along with a backslash, and see if you have better luck?

Brian

Dec 1, 2010 at 12:21 PM

That did the trick, thanks.